Welcome

Please register for Total War Access to use the forums. If you're an existing user, your forum details will be merged with Total War Access if you register with the same email or username. For more information please read our FAQ’s here.

Categories

The Total War launcher beta update and feedback thread.

2

Comments

  • celia_cacelia_ca Posts: 23Registered Users, Moderators, Administrators, CA Staff
    Ectelion said:

    sorry in advance i am not a native speaker :=)

    first issue:
    the launcher takes about 1-2 minutes to delete a mod without cancelling its subscription

    second issue: the mods deleted reappear after restarting the launcher

    third: refresh button not working at all


    suggestion: it would be nice to be able to open the mod itself on the workshop (like the previous launcher) it's a small thing but very important to me, sometimes in order to see other mods requested and comments.

    edit: sorry i didn't see the link to the workshop in the info panel,so i would restore the way of the older one, i mean accessing to the steamworkshop by clicking on the name of the mod without the need to open the info.
    Also i noticed that you can open only the info panel if the mod is enabled, please let us do it in any case.

    edit 2: clicking disabling all the mods, launching the game and restarting it = keeps loading and it says 0 subscriptions (i checked on the workshop and its all fine there)

    https://imgur.com/JoUe7Up

    so far i didn't manage to solve the problem, all my mods seem to be vanished.
    i went back to the old launcher, it sees my mods, i updated again to the new one, still 0 mods...
    I also noticed that the mods that resulted as "cloud faded" loaded perfectly on the old one.

    sorry for the confusion/amount of informations, i hope to help.

    thanks!

    Thanks a lot for the feedback. The dev team is currently working on improving certain reported issues with the Mod Manager. Can you please let us know how many mods you are currently subscribed to for the game? And is this happening for subscribed mods only or for your own created mods?

  • Surtur32Surtur32 Posts: 1Registered Users
    edited December 2018
    I like new launcher! But have one question: what's up with older Total War titles - Medieval 2, Rome, Napoleon, Empire, Shogun 2, etc.? There will be one launcher for all Total War games, or just they will be updated, and there will be sepatate launcher for this games too, like latest Total War releases? Thanks for your respondes :)
  • EctelionEctelion Posts: 13Registered Users
    celia_ca said:

    Ectelion said:

    sorry in advance i am not a native speaker :=)

    first issue:
    the launcher takes about 1-2 minutes to delete a mod without cancelling its subscription

    second issue: the mods deleted reappear after restarting the launcher

    third: refresh button not working at all


    suggestion: it would be nice to be able to open the mod itself on the workshop (like the previous launcher) it's a small thing but very important to me, sometimes in order to see other mods requested and comments.

    edit: sorry i didn't see the link to the workshop in the info panel,so i would restore the way of the older one, i mean accessing to the steamworkshop by clicking on the name of the mod without the need to open the info.
    Also i noticed that you can open only the info panel if the mod is enabled, please let us do it in any case.

    edit 2: clicking disabling all the mods, launching the game and restarting it = keeps loading and it says 0 subscriptions (i checked on the workshop and its all fine there)

    https://imgur.com/JoUe7Up

    so far i didn't manage to solve the problem, all my mods seem to be vanished.
    i went back to the old launcher, it sees my mods, i updated again to the new one, still 0 mods...
    I also noticed that the mods that resulted as "cloud faded" loaded perfectly on the old one.

    sorry for the confusion/amount of informations, i hope to help.

    thanks!

    Thanks a lot for the feedback. The dev team is currently working on improving certain reported issues with the Mod Manager. Can you please let us know how many mods you are currently subscribed to for the game? And is this happening for subscribed mods only or for your own created mods?

    thanks for the answer, i m currently subscribed to 141 mod, it's happening for every mods, mine as well.
  • Draco100000Draco100000 Posts: 2Registered Users
    Last time I wrote about the launcher I was able to use it perfectly. Today i just tried to get into my modded campaing, but for some reason the launcher is not activating any of my mods. i dont know What is causing the issue. I will roll back to standard version for now.
  • Tom_RokzoTom_Rokzo Posts: 1Registered Users
    Hello dear CA. Question about the new launcher - will be added the ability to run add-ons for Medieval 2 directly from the launcher?
  • Haradrim95Haradrim95 Posts: 1Registered Users
    Evening

    Came across quite a bad bug when using the new mod manager.

    When activating a mod, the whole launcher screen turns dark grey. There is no way to solve this issue other than closing it down and starting it back up just for the launcher to turn grey again when activating another mod.

  • Frodo45127Frodo45127 Junior Member Posts: 9Registered Users
    celia_ca said:

    Tried to upload a mod with the new launcher and I got this:

    @Frodo45127 Thanks for the feedback, were you able to upload the mod after trying again, or did you see this error every time? Also, did this affect one mod only, or different mods?
    Sorry for taking so much time to answer, didn't saw the response. Despite that error, the mod was uploaded (new mod, not updating an already uploaded one), but the steam workshop wasn't automatically open in the browser like it usually does when it's done uploading. Haven't tried uploading a new mod again.
  • celia_cacelia_ca Posts: 23Registered Users, Moderators, Administrators, CA Staff
    Thanks a lot for your feedback and replies. The dev team is actively working on the problems reported with the Mod Manager.

    And also thanks for the additional feature suggestions as well! We will pass these over to the team for consideration for future releases.
  • celia_cacelia_ca Posts: 23Registered Users, Moderators, Administrators, CA Staff

    Last time I wrote about the launcher I was able to use it perfectly. Today i just tried to get into my modded campaing, but for some reason the launcher is not activating any of my mods. i dont know What is causing the issue. I will roll back to standard version for now.

    Thanks for the info @Draco100000 can you confirm if this happened on WARHAMMER I or a different game?
  • WestonGWestonG Posts: 3Registered Users
    The mod manager presents a solid grey screen.
  • neoiq5719neoiq5719 Senior Member Posts: 178Registered Users
    edited January 3
    The mods dont seem to load with the new launcher so I went back to the old one and they work now. Something is going on with this new one.
    Post edited by neoiq5719 on
  • DumbledoodDumbledood Posts: 3Registered Users
    edited January 3
    Just thought I'd also say that the ability to save profiles or sets of mods to be used in conjunction with each other would be great, and is really the only thing missing from the new mod manager.

    Otherwise, the new launcher looks a lot cleaner, and thank you for taking the communities feedback into consideration as well as continuing to support the game in various ways. Happy new year!

    Edit: Any super rough estimates on when this will be released for TWWH2? Judging by the bug reports, not for a little bit.
  • JiushiJiushi Posts: 3Registered Users
    edited January 13
    This was probably suggested before but please take a good look at Kaedrins Mod Manager. It has some awesome features like the possibility to save different profiles/modlists for the same game (must have) or that it shows possible conflicts etc.

    https://steamcommunity.com/sharedfiles/filedetails/?id=1399787504
    https://www.reddit.com/r/totalwar/comments/8kadex/kaedrins_mod_manager_news/

    Or to say it bluntly, just copy the features you see on these sites and you got what we want/need for a good mod manager. If you do so I think Kaedrin would also love to hear from you guys in person.
    Post edited by Jiushi on
  • MuhsinTpdMuhsinTpd Junior Member Türkiye Cumhuriyeti (The Republic of Turkey)Posts: 114Registered Users
    You can add Assembly Kit Button on launcher.
    “Victory is for those who can say "Victory is mine". Success is for those who can begin saying "I will succeed" and say "I have succeeded" in the end.”
    ― Mustafa Kemal Atatürk
  • TheGuardianOfMetalTheGuardianOfMetal Senior Member Posts: 9,010Registered Users
    edited February 6
    Dear CA,

    'd like to suggest to add the ability to save Mod "presets" for games, allowing to save mod combinations. For example, taking Rome II here, One preset could then be "Divide et Impera/DeI", anothe rone could be "Vanilla Enhanced" etc.

    Or for TW WH2: One Preset could be "Mixu's mods,etc-" another one could be "Vanilla Enhanced", and again another one could be "Cataph's stuff and other"

    This would allow a quick, and easy, switch between differently modded campaigns.

    It'd also allow decent mod testing. If you stumble into mod related crashes, you can just switch into the working combination isntead of trying around for ages.

    I'd also suggest to allow us to, together with dragging a mod into the loading order, we should be able to just type inthe number where it is intended to launch. The one after it could then simply skip.

    So let's say you want Mod 30 to launch second. you'd click ones on it, type in "2", and MOd "2" would automatically become "3" and so on.

    Also, it seems the launcher crashes when i work with roughly 130 Mods :blush: not all activated of course...
    Post edited by TheGuardianOfMetal on
    Every wrong is recorded! Every slight against us! Page after Page, etched in blood! Clan Gunnison! Karak Eight-Peaks! Josef Bugman!

    Yes! to Boris Todbringer as playable, subfaction leading Legendary Lord with Starting Position Middenheim instead for the Empire! NO to the lazy way of moving Gelt and Volkmar who both belong to Reikland!

    Where is Boris Todbringer? Have you seen him?
  • celia_cacelia_ca Posts: 23Registered Users, Moderators, Administrators, CA Staff
    @TheGuardianOfMetal Thanks a lot for the feedback, we will be passing it to the dev team for consideration for future releases.

    Regarding the Launcher crashing with over 100 mods, can you please give us more information on the version number in the Launcher (in the help menu), how often are you encountering this and any actions that might be causing this (does it happen when loading the launcher, trying to play, deleting mods...)? This will help us investigate this further.
  • SerkeletSerkelet Member Posts: 323Registered Users
    edited February 17
    My friends and I encountered an issue that is definitely related to the beta launcher. We use lots of mods, specifically 63 mods at the moment. When using the beta launcher the game would arbitrarily consider our versions incompatible making it impossible for us to play multiplayer campaigns. The issue was immediately solved as soon as we went back to the normal launcher.

  • VaelthrisVaelthris Junior Member Posts: 31Registered Users
    I am not sure if this is an issue with Steam, the Launcher or both.

    The new launcher seems to, very often, completely erase the description of updated mods as well as a general failure to update. No error codes, nothing, the update just doesn't go through.

    Furthermore, weird issues are happening to mods updated with the new launcher. GCCM Island Battles forces users to keep the mod enabled (mod gets ticked every restart, no matter the user input) along with redownloading every time the launcher starts, for some other users.

    aka Marthenil

    My Steam Workshop
  • PrussianWarfarePrussianWarfare Posts: 9Registered Users
    Sent here due to OtherTom.

    Don't know if it has been requested yet, but both modding profiles and a better visual way to show you finished updating a mod would be great.

    Modding profiles allow people to save up a specific profile for a specific campaign they are doing, and then allow the easy switch to a different profile if they want to resume or play a different campaign.

    Secondly, the current way to know if a mod is updated is a timed pop up on the launcher in the top right hand corner, or checking your mod page. If you're not paying attention to your screen then it's easy to miss that notification. If there was a better way to showcase that the mod got updated then that would be superb.
  • celia_cacelia_ca Posts: 23Registered Users, Moderators, Administrators, CA Staff
    edited February 19
    Thanks for taking the time to test he new Launcher and report issues, it is really appreciated. These have been passed over to the team.

    We are noting all your requests for a mod profiles feature, and will make sure this is passed on as well :)
  • CA_NateCA_Nate Creative Assembly Posts: 944Registered Users, Moderators, CA Staff Mods, CA Staff
    Hi @Serkelet

    Would it be possible for you and your friend to provide us with both of your Modified.Log files.

    If you have any issues finding these files please refer to the link below:

    https://forums.totalwar.com/discussion/173602/how-to-find-your-modified-log-file

    Kind Regards,

    CA_Nate
    Forum Terms & Conditions

    Formal disclaimer: any views or opinions expressed here are those of the poster and do not necessarily represent the views or opinions of The Creative Assembly or SEGA.
  • celia_cacelia_ca Posts: 23Registered Users, Moderators, Administrators, CA Staff
    Vaelthris said:



    Furthermore, weird issues are happening to mods updated with the new launcher. GCCM Island Battles forces users to keep the mod enabled (mod gets ticked every restart, no matter the user input) along with redownloading every time the launcher starts, for some other users.

    Hi @Vaelthris, could you please try to delete the Launcher folder and let us know if the issue with the GCCM Island Battles mod persists? You can find this folder in: User\AppData\Roaming\The Creative Assembly\Launcher

    Many thanks,
    Celia

  • SaSemarSaSemar Posts: 1Registered Users
    Hi CA.

    First off, props for making the new launcher so much more convenient and comfortable than the previous one. I´ve enjoyed using the new launcher for a while but sadly I encountered a bug.

    I have made a few maps and was in the process of testing a new one I am making, but for some reason even though I had the mod active in the launcher it was not showing up in-game. In addition to this, for every mod I deleted whilst I was using the new launcher a strange mod showed up in the launch screen as seen here:

    https://imgur.com/a/kunwmKu

    I believe these two issues are related, as upon opting out of the beta and using the old launcher again my maps started working again, and are the only mods shown:

    https://imgur.com/a/vzamGfd

    Going back to the old launcher feels bad after using the new one, I hope this helps you solve this issue.
  • VaelthrisVaelthris Junior Member Posts: 31Registered Users
    @celia_ca

    I'm Marthenil on the workshop, one of the mod authors for the mod. A lot has been tried, including reinstalling the game and updating with the old launcher (again). This can't be an end user issue, since we get a lot fo reports from different users of the same thing happening.

    aka Marthenil

    My Steam Workshop
  • celia_cacelia_ca Posts: 23Registered Users, Moderators, Administrators, CA Staff
    edited February 20
    @Vaelthris Sorry, I didn't realise you were one of the authors. We fixed an issue that was affecting GCCM Island Battles and possibly other mods some time ago, but we will look into this again. Thanks for the info :)
    Post edited by celia_ca on
  • CA_NateCA_Nate Creative Assembly Posts: 944Registered Users, Moderators, CA Staff Mods, CA Staff
    edited February 20
    Hi @SaSemar

    Before you run the Launcher_openbeta again would you be able to delete your Launcher appdata folder which can be located here: User\AppData\Roaming\The Creative Assembly\Launcher

    Loading the Launcher_open beta after this will regenerate the folder.

    Kind Regards,

    CA_Nate
    Forum Terms & Conditions

    Formal disclaimer: any views or opinions expressed here are those of the poster and do not necessarily represent the views or opinions of The Creative Assembly or SEGA.
  • VaelthrisVaelthris Junior Member Posts: 31Registered Users
    edited February 20
    @celia_ca Yeah, sorry, I should've clarified.

    aka Marthenil

    My Steam Workshop
  • robo86844robo86844 Posts: 3Registered Users
    edited February 26
    So today i wanted to play Total War Warhammer II with 71 mods i have i played with all the mods on before but today there is the new launcher and Total War Warhammer II wont even start any more the launcher it self crashes is there a way to get the old launcher back because i want to play with all my mods again.
  • AkinoAkino Posts: 2Registered Users
    Hi,

    Is there a way to edit mod tags when re-uploading them especially when you added features and want to change them for example from "Units to Campaign", "Graphical to Units", "Campaign to Overhaul", et cetera.

    Thanks!
    Akino
  • DJTobyDJToby Posts: 1Registered Users
    Hi, unfortunately my beta mod launcher fails to launch properly instead I only get a loading screen which fails to load the mods. I have tried in two different houses and nothing has loaded. Any ideas guys?


Sign In or Register to comment.