Welcome

Please register for Total War Access to use the forums. If you're an existing user, your forum details will be merged with Total War Access if you register with the same email or username. For more information please read our FAQ’s here.

Categories

new computer and rome 2 wont go past the launcher...

thedesertfox151thedesertfox151 Posts: 1Registered Users
to anyone who is reading this i recently got a new and better computer so i could finally my total war games on high graphic settings. Me being the person i am(loving history) couldn't wait to plat Rome 2 on the best setting possible, but after i downloaded it and my other total war games it doesn't want to go past the launcher where you press the play button. the play button just changes to a darker color and nothing happens. my other total war games like napoleon and shogun 2 don't have this problem, but that may be because they don't use the same launcher as Rome 2 i simply hit play on steam and they start right up. i have looked into other discussions about this but i can't seem to figure it out any help would be very appreciated!

Comments

  • MajorDonglesMajorDongles Posts: 3Registered Users
    edited March 10
    Hi

    First things first, you need to try and reinstall the game. If the problem continues, then there might be something wrong with your system on the OS - level of things (Driver issues, registry errors etc).

    If the problem is still there after a succesful reinstall, try updating your drivers. After that you could try cleaning your OS's registry with CCleaner (or any other similiar software). Just remember to take a backup of the registry first. Cleaning up all the other useless files from the cache etc might be useful as well. CCleaner is good for that too.

    That should do it.
  • Mr_ShenpaiMr_Shenpai Junior Member Posts: 4Registered Users
    I've got the same problem, Except I was playing it about an hour before this happened, downloaded a few mods, and tried to start it back up, and that's when the launcher greys out when I click the play button. I've cleared my mods list, so it's just the base game, I've tried reinstalling every game that uses the launcher and its still not working.
  • BillyRuffianBillyRuffian Moderator UKPosts: 35,872Registered Users, Moderators, Knights
    Try deleting the launcher folder in %appdata\Roaming\The Creative Assembly\Rome 2

    "He uses statistics as a drunken man uses lamp-posts - for support rather than illumination." (Andrew Lang)

    |Takeda| Yokota Takatoshi

    Forum Terms and Conditions: - https://forums.totalwar.com/discussion/172193/forum-terms-and-conditions#latest

    "We wunt be druv". iot6pc7dn8qs.png
  • Mr_ShenpaiMr_Shenpai Junior Member Posts: 4Registered Users

    Try deleting the launcher folder in %appdata\Roaming\The Creative Assembly\Rome 2

    I've tried that, and it doesnt seem to have worked. but i did find something that does, simply reverting to the old launcher.

    1.Open Steam

    2.Open Games Library

    3.Right click on Rome 2 and select properties

    4.Navigate to "Betas"

    5.Select launcher_release_candidate

    That worked for me for now.
Sign In or Register to comment.