Welcome

Please register for Total War Access to use the forums. If you're an existing user, your forum details will be merged with Total War Access if you register with the same email or username. For more information please read our FAQ’s here.

Categories

WarHammer 2 not launching

Blueeyes27Blueeyes27 Registered Users Posts: 2
I just bought the game off steam,I uninstalled it twice thinking that would fix it I've checked the integrity of files it says everything is fine..I try to launch it screen goes black then takes me back to the home screen???
PLEASE HELP!!!!

Comments

  • f95f95 Registered Users Posts: 4
    edited March 2019
    I think I’m also having a similar problem…

    PROBLEM: In the launcher I click “Play” and the Play button remains “clicked” but the game doesn’t start. When I go to the mod manager the game remains thinking always.

    I try to delate all mods, check the integrity of files, and I uninstalled the game, but the problem remains.

    I attached the images of the crash, and the DxDiag, preferences and modified.log files.

    I hope somebody could help me, thank you!
  • f95f95 Registered Users Posts: 4
    The new launcher is the problem.

    I revert to the old launcher in the beta section of warhammer II (right click--> Properties-->Betas-->Launcher release candidate, and the game starts :)
  • GibbanatorGibbanator Junior Member Registered Users Posts: 6
    edited September 2019
    I got same problem as you f95 but that trick didnt work for me

    was working fine yesterday. it just started today
  • GibbanatorGibbanator Junior Member Registered Users Posts: 6
    I got it to work.. had to change the compatibility

    Open Steam
    right click your game
    choose properties
    click the Local Files tab
    click the Browse local Files
    right click your games EXE
    choose properties
    click Compatibility tab
    Click "Run compatibility troubleshooter"

    Mine was changed to Windows 8 now the game launches normally.

    if you have different users than make sure you click the "Change settings for all users" at the bottom
  • SrangSrang Registered Users Posts: 3
    There is this other problem that I HAD FOR YEARS without realizing since I thought that cant be it since it asks me for permission (admin) every time before starting BUT MANY MANY of you will be unable to launch under windows 10 because you don't start the steam app UNDER ADMINISTRATOR (The steam app NOT the Game!!!). I had this problem FOR YEARS and tried everything from now and then again to get it to run but it never went beyond the LAUNCHER-.-. Then i admined steam icon and it all worked I was SO SO angry...

    >CLOSE STEAM (completely)
    >Go to the desktop or window start icon
    >RIGHT CLICK on it
    >Go Compatibility on the top (6 little tabs)
    >click change settings for all users
    >then click run this program as admin and apply then ok and close
    >start steam
    > And start the Game.

    I had this problem NO OTHERS NO Driver things ALL OTHER GAMES even Warhammer 1 WORKED NORMAL...EXCEPT Warhammer 2 NO PROBLEMs...it would go to launcher but then NOT start although asking me for Permission before starting and everything I would click OK then it would just go back to Play from Running in the steam library. And I really tried EVERYTHING but nothing worked...It's THIS since I changed this EVERYTHING runs perfectly.
  • animeboingboinganimeboingboing Registered Users Posts: 1
    Ever since they did this update. Cant play the game anymore. Deleted the creative assembly foldier. Set compatibility mode didnt work. changed the launcher didnt work. The heck someone plz help. Oh also keep asking permission about something so IDK.

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file