Please register for Total War Access to use the forums. If you're an existing user, your forum details will be merged with Total War Access if you register with the same email or username. For more information please read our FAQ’s here.


Multiplayer campaing head to head doesn't load

WilOnilWilOnil Registered Users Posts: 3

Yesterday a friend and I tried to start a new head to head Mortal Empires campaign and it proved impossible. We tried many times, and each of them, we ran into one of the following problems:

1) When he hosted the campaing, I couldn't even join at the lobby. Either I got the message "Unable to join game", or my game would freeze in the gray screen and I had to Alt+F4

2) When I hosted the campaing, he could join and we could launch the campaign. However, when getting into a battle, we both would get stuck in the "Waiting for the other player to load" screen, and get kicked out after waiting the 5 minutes.

Some info in case it's helpful:
- Just prior to this, I had some problems (a crash) with the new launcher, but Steam did his thing and in the end I could enter the game with no issue. I don't know if this is maybe related.
- We had some mods at the beggining, but we disabled them and tried a couple of times again. No change.
- We both have very decent hardware and internet connection.


Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file