Welcome

Please register for Total War Access to use the forums. If you're an existing user, your forum details will be merged with Total War Access if you register with the same email or username. For more information please read our FAQ’s here.

Categories

Three Kingdoms won't use the correct graphics card to run

waisiulowaisiulo Posts: 3Registered Users
edited May 2019 in Performance & Graphics
Build:
Intel(R) Core(TM) i7-8750G CPU @ 3.10GHz 3.10 GHZ
16.0 GB RAM
Windows 10 64 bit
Radeon RX Vega M GL card

Detailed description:
I tried to run the game on a dell XPS 15 laptop but every time it uses the Intel HD graphics instead of the on board Radeon RX Vega M GL card, please help!

Reproduction Steps:
N/A

Screenshot:
attached.

Details of any solutions that have already been attempted:
1. Reinstalled the graphic drivers and also the intel graphic drivers with no luck.
2. Reinstalled the game.

Please attach DxDiag
attached.
Tagged:

Comments

  • BillyRuffianBillyRuffian Moderator UKPosts: 36,571Registered Users, Moderators, Knights
    From the FAQs on the SEGA Support site:

    To set a preferred graphics processor for your Total War game, using AMD Switchable Graphics Technology:
    1.Ensure that you have the latest GPU drivers from either your Laptop’s manufacturer’s official website or AMD’s website.
    2.Right-click on the desktop and select ‘AMD Radeon Settings’.
    3.Select 'Preferences' and then 'Radeon Additional Settings'.
    4.Navigate to Power and select Switchable Graphics Application Settings to see a list of recent applications and which GPU they are using. Search for the games start exe file and choose 'High performance'.
    5.If the games exe is not found in the list, please add it manually. Navigate to Radeon Settings > Preferences > Additional Settings > Power > Switchable Graphics Application Settings and the click Add Application and navigate to the games folder and select the games exe file.
    6.Once you have selected your preference, click ‘Apply’ in the bottom right corner to confirm & apply.

    NOTE: Some laptop computers will not run with the second more powerful discrete graphics card unless connected to the mains AC.

    "He uses statistics as a drunken man uses lamp-posts - for support rather than illumination." (Andrew Lang)

    |Takeda| Yokota Takatoshi

    Forum Terms and Conditions: - https://forums.totalwar.com/discussion/172193/forum-terms-and-conditions#latest

    "We wunt be druv". iot6pc7dn8qs.png
  • waisiulowaisiulo Posts: 3Registered Users
    edited May 2019
    Thanks BillyRuffian, I just tried these but I couldn't locate Radeon Additional Settings and Power and so on...
  • BillyRuffianBillyRuffian Moderator UKPosts: 36,571Registered Users, Moderators, Knights
    Sorry, I can't help with that - I'm not an AMD user.

    "He uses statistics as a drunken man uses lamp-posts - for support rather than illumination." (Andrew Lang)

    |Takeda| Yokota Takatoshi

    Forum Terms and Conditions: - https://forums.totalwar.com/discussion/172193/forum-terms-and-conditions#latest

    "We wunt be druv". iot6pc7dn8qs.png
  • GrudgeNLGrudgeNL Senior Member Posts: 7,179Registered Users
    waisiulo said:

    Thanks BillyRuffian, I just tried these but I couldn't locate Radeon Additional Settings and Power and so on...

    Does this suggestion help?
    https://community.amd.com/thread/222533

    Just for clarification, please be aware that the settings that were in "Additional Settings" have not been deleted, just moved to the Display menu, also note that further control settings can be found by clicking on the "Color" icon in the Display menu.
    Grudge's Mods
    Total War: Karling - Coming soon...-ish
    Grudge's Total War: Attila - Sassanid UI skin here on the Steam Workshop
  • djay787djay787 Posts: 2Registered Users
    on this HP/AMD/Radeon notebook both the above needs doing but also in the windows manin graphics settings also ... desktop > right click > display settings > (scroll down to) graphics settings > add TW3k to the list > click on it > click options > set to high performance (default is not power saving or performance,

    this changed things from annoying intermmitent frame drops ( twice as annoying when you know your machine is capable of running the program) and now it only drops frames in double stack battles,

    in short with some software doing this in the grahpics card software is not enough, it has to be set to high performance in both ways
Sign In or Register to comment.