Welcome

Please register for Total War Access to use the forums. If you're an existing user, your forum details will be merged with Total War Access if you register with the same email or username. For more information please read our FAQ’s here.

Categories

Error:Failed to join game Unspecified Error

sololatesololate Posts: 1Registered Users
I have started two different campaigns with my friends and every time I try to join the game I get Unspecified Error. I reinstalled windows, reinstalled the game, verified the files, deleted the files in appdata, tried with vpn, started new campaign, tried with another friend, reset my route. I have done everything that I could think of and I can rarely connect successfully. Sometimes after restarting steam or deleting the files in appdata I get it to work, but it seems to happen randomly and rarely works.

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file