Please register for Total War Access to use the forums. If you're an existing user, your forum details will be merged with Total War Access if you register with the same email or username. For more information please read our FAQ’s here.


In ProgressAre you ever gonna fix this issue!!!

Immortal10Immortal10 Posts: 1Registered Users
edited July 2 in Performance & Graphics
I bought the three kingdoms yesterday and today I got the problem. I looked into the forum and found these complaint threads with the same issue:




and many more. I am surprised that the devs are still ignoring this bug even though it had been there for a month now. Are the devs gonna fix it or shall I suggest my friends (who are willing to buy this game) not to buy this game as it is full of bugs and the devs are not willing to fix it.
Post edited by CA_Nate on


  • CA_NateCA_Nate Creative Assembly Posts: 1,036Registered Users, Moderators, CA Staff Mods, CA Staff

    We are aware of this issue, taken all the information from created threads and our QA team are actively investigating it. :smile:

    Kind Regards,

    Forum Terms & Conditions

    Formal disclaimer: any views or opinions expressed here are those of the poster and do not necessarily represent the views or opinions of The Creative Assembly or SEGA.
  • pblake81239pblake81239 Posts: 3Registered Users
    Just bought the game and got this issue!! Any updates on this?
  • Daemonprince14Daemonprince14 Senior Member Posts: 326Registered Users
    At this point in time, I think there is more chance of me winning the lottery and becoming king of the planet before Creative Assembly fix this issue. It has been out for a while now with very little information and feedback by creative assembly. The game is essentially broken and should never have been published... and don't try to convince me that CA and SEGA never knew about this problem, because I simply don't believe it.

    It is unfortunate really, total war has been a very big part of my life so far, and mostly it has been an excellent experience. However, I paid £45 for the special edition of total war three kingdoms (I have always buy special editions of the total war games, but decided to cancel the £150 version a few weeks before release, glad I did) and have so far not been able to play it past 30 turns, over a month ago when the bug occurred, which annoys the life out of me.

    I have therefore decided NOT to purchase anything else, AT ALL, from SEGA or the Creative Assembly until this issue is fixed, which I am beginning to think it won't be.

    I hardly think that me not buying anything else from SEGA or Creative Assembly will bother them in the slightest, such is the state of apathy in this age, but it will certainly save me a lot of money and time with two company's that frankly don't deserve the status they have.

    I will of course keep an eye on the progress of this game, and hope the issue eventually gets fixed, but I won't be holding my breath while I wait.

    Take care!
  • Daemonprince14Daemonprince14 Senior Member Posts: 326Registered Users
    edited August 5
    FAO: Immortal10

    Hi buddy, just though I would drop in a little advice if you are still having the same issue. I had given up on the game until my girlfriend decided to tinker around with it. We had already taken the necessary steps of clearing system cache, updating drivers, changing settings etc. with no luck, however, my girlfriend decided to take the game back 10 turns to an earlier save game and re-play it from that point. (I would for this reason suggest the use of the new autosave feature the game has just in case it happens again).

    Well... issue no longer persists... at least for now. I started a new campaign and am now well into becoming an empire without any problems whatsoever. The game itself is fantastic, but as I have said many times before, total war games are excellent AFTER being released and patched several months after official release date. Personally, I think they have rushed the games onto the market in a beta state since Empire Total War (which incidentally, is the most bugged and broken game I have ever attempted to play).

    Regardless, try a new campaign or take it back several turns before the issue occurs. Hopefully this will remedy the issue.

    I did have an issue with someone on social media telling me that this issue did not exist and that my computer must be ancient. Well, clearly it is (or was) an issue, but my computer easily complies with the recommended specifications and when the game works, it runs very well. Hope this helps.
  • Tryndaweniger_Tryndaweniger_ Posts: 1Registered Users
    So what the hell is happening here?

    Almost 2 more months have passed yet no information from CA besides "we're working on it".

    Come on don't tell me it takes you 3 months to fix a bug. Are you even working on this?

    To me it looks like they don't even care about fixing this really.

    Just bought the game and less than an hour in I ran into this "blank campaign camera"-bug was like ehh that's not a big deal there's gotta be a fix many months after the game was released but uhh guess what there's still no fix for it.

    I could restart campaign and hope it doesn't happen again but **** this I'm not down to get this bug something like 200 turns into the game.

    CA please fix this bug or else I'll be really mad
  • RamblinManRamblinMan Posts: 2Registered Users
    I'm having the same problem. Map is stuck in fog... or something. I don't know. It won't let me move it and I just declared war on the faction which killed Cao Cao's father.

Sign In or Register to comment.