Welcome

Please register for Total War Access to use the forums. If you're an existing user, your forum details will be merged with Total War Access if you register with the same email or username. For more information please read our FAQ’s here.

Categories

Fix the Multicore Affinity bug.

rafantomasrafantomas Posts: 649Registered Users
edited July 21 in Technology
I think CA should totally focus on fixing the multi-core affinity bug cause It's unbearable that people have to be teaking core threadings to fix a game that costs 60$?? They've been having this problem since Rome and yet can't fix it? It totally works and it's lazy to leave the modders to fix it. People goes from medium settings to ultra just bi right clicking some stuff on their ctrl+shift+esc.

Any news or comments about fixing this?

@ca anyone.
Post edited by BillyRuffian on

Comments

  • PancakesPancakes Posts: 377Registered Users
    edited July 20
    Are you refering to disabling virtual AMD SMT cores?
    That would only apply to ryzen chips and after testing does not give any noticable improvements in TWWH

    After looking up the "bug"

    Disabling core 0 and 1 locks CPUs from boost clocking,. It shouldn't give any major boost. And would be counter intuitive on any high end cpu with boost clocking.
    Very dependent on your CPU and how well it's multithreading works,. As working on multiple cores has its pros and cons.

    It will most likely be fixed when DX12 gets updated in the coming months. As in DX11 TWWH doesn't take advantage of multicore setups.
    It's still a 3 year old beta after all.

    If your looking for a small boost, try isolating your OS to a different core than TWWH
  • psychoakpsychoak Posts: 2,327Registered Users
    You've conjoined bugs.

    SMT and hyper-threading, largely the same thing, result in virtual cores. You don't actually have core 0 and core 1, they're both core 0. Every other core is fake, it's partially duplicated resources, running on the same physical core.

    Theoretically, your second fake core can nearly double the output of a task that mostly uses those shared assets, but when you're running processes that bottleneck on the non shared resources, it's 50% of what is shown available. Typical task loads run around 60%.

    So you go in and disable the odd cores(not 0 and 1) for the game, and effectively turn off SMT, which old software tends to not benefit from(old old, like Y2K old). If Warhammer was burning down the virtual core and the real core at the same time for it's active and inactive GPU threads, instead of using two different cores, you've just greatly reduced a major performance problem.

    The game is very highly threaded, even DX11 does use more than one core, and Warscape 3 itself is more than just a graphics engine, the AI will use every other core you've got, up to at least the i9 9980XE's 18 cores, with the graphics running on two of them.

    For disabling 0 and 1, there is potentially another issue with the way Windows handles the NUMA nodes in Threadripper, but I've seen reference to a hotfix patch that fixes it, as well as AMD information debunking that there is a problem, though perhaps this is post hotfix and the issue did exist. In this case, disabling the first two cores would break the decision making for preference towards the first set of cores and resolve the problem.

    As far as I'm aware, any potential issues here should already be addressed. Warscape 3 most certainly handles hyper-threading appropriately, and Windows itself does most of the scheduling. Provided the NUMA hotfix exists, and you don't have it, there may be a resolution to your problem readily available via Windows Update.
  • psychoakpsychoak Posts: 2,327Registered Users
    This might be your problem:

  • dge1dge1 Moderator Arkansas, USAPosts: 18,633Registered Users, Moderators, Knights
    Not a Warhammer discussion. Moved.
    "The two most common things in the universe are Hydrogen and Stupidity." - Harlan Ellison
    "The right to be heard does not automatically include the right to be taken seriously." - Hubert H. Humphrey
    "Never argue with an idiot. They will only bring you down to their level and beat you with experience.” - George Carlin
Sign In or Register to comment.