Welcome

Please register for Total War Access to use the forums. If you're an existing user, your forum details will be merged with Total War Access if you register with the same email or username. For more information please read our FAQ’s here.

Categories

Game Crash upon launch

its_jack_reevesits_jack_reeves Posts: 1Registered Users
When launching Shogun 2 from Steam and selecting either direct x9 or x11, the game launches then immediately enounters a problem and closes. I have tried verifying the game files and updating graphics drivers but that does not seem to work.

It is not a problem of how old the game is either, as both Rome 1, Medieval 2 and all the games after Shogun 2 work perfectly fine.

Becoming a bit annoying as I have deleted and redownloaded it many times to get the same result. It's a shame as when I first had it, it was brilliant :( Help a bloke out lads

Comments

  • easytargeteasytarget Senior Member Posts: 2,406Registered Users
    edited September 21
    I dropped by to bring this to CA's attention so they're aware that the current Steam beta crashes this game.

    The game runs to load, you get initial Shogun 2 splash screen, cursor changes to a spear tip, then the game closes back up and fails to actually run.

    The current fix is relatively easy, just drop back out of the steam beta and the game works fine.

    Take note CA, if you don't connect up with Valve on whatever it is they're doing with their current steam beta, if it's not fixed when that beta becomes main branch this game will no longer work for anyone.
    This space intentionally left blank.
Sign In or Register to comment.