Welcome

Please register for Total War Access to use the forums. If you're an existing user, your forum details will be merged with Total War Access if you register with the same email or username. For more information please read our FAQ’s here.

Categories

Tehenhauin quest chain can not progress when confederated.

OogbladOogblad Registered Users Posts: 1
edited September 2019 in Campaign & Battle Bugs
The quest chain for "Plaque of Sotek" stops after completing the amass 5000 treasury step when not playing as cult of sotek.

I think this is because the next step would require the sacrifice mechanic witch is exclusive to cult of sotek.
Maybe it is possible to make the quest chain skip that step instead of just not progressing when the faction is not cult of sotek.

In this screenshot you can see the quest step complete but not trigger the next step.
(I completed the previous step the same turn so that is the top set of completed/issued.)



Build nr: 11694.1746401

The save file is one turn after because i wanted to see if it would still trigger the next turn.

I hope this information helps and this can be fixed soon as it made me kind of sad to lose such a powerful item to this bug.

Edit: added my empty modified.log

Comments

  • furtissimfurtissim Registered Users Posts: 370
    This is a problem... CA fixed it in the case of Morathi (if you played with Hellebron and confederated Morathi, you couldn't do the rite of Hekarti so Morathi's quest stopped). A few patches later they fixed it for her, but there's still the problem with Tehenhauin and (now) Gor-Rok for whom you need to use their faction-specific mechanics...

    Please CA, fix this 2 and avoid linking legendary item quests with faction-exclusive mechanics!
  • AdrianKarrantzaAdrianKarrantza Registered Users Posts: 56
    I had a similar problem when I confederated Gor-Rok playing as Nakai. I can no longer fulfill the quest objectives since the "Rite of Resilience" is specific to Itza, and it is not available for the other Lizardmen factions. LINK: https://forums.totalwar.com/discussion/250712/gor-rok-s-questline-the-shield-of-aeons-bugged-if-gor-rok-is-confederated/p1?new=1

    Apparently other Lizardmen LLs have similar issues. Mazdamundi´s questline, for example, requires to build a specific building, but Nakai is unable to build settlements. LINK: https://forums.totalwar.com/discussion/250750/no-ll-item-quest-after-nakai-confederates#latest
  • Oz1066Oz1066 Registered Users Posts: 1
    Also had the Plaque of Sotek quest line stop after the Amass 5000 treasury step when I confederated him as Gor-Rok. I had thought the last patch had notes in it that they fixed this. Apparently CA only insured that you can trigger the Legendary Item quests for confederated lizardmen LL not that you can complete them. Can we get this reverted back? I would rather not have the quest line trigger than go 90% of the way down a quest line quest to have it die.

    My mistake, I read through the patch notes again, they only fixed the quests for lizardmen LL when you confederate as Nakai.

    Playing with the King's Shilling Beta.
  • ConfusedLynxConfusedLynx Registered Users Posts: 2
    Same thing happened to me. Playing as Gor-Rok, confederated Sotek, and quest for Tehenhauin stopped after the 5000 step. Not playing with any mods, but with all DLCs and the game is up to date (5.14.20). If it helps, I also had 5000 gold when I got that quest, and so both quests were finished simultaneously. At first, I thought this might've been what triggered the bug.

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file