Welcome

Please register for Total War Access to use the forums. If you're an existing user, your forum details will be merged with Total War Access if you register with the same email or username. For more information please read our FAQ’s here.

Categories

I FIXED THE CRASH ON SPLASH SCREEN BUG- Try this.

newbornleenewbornlee Posts: 4Registered Users
After ENDLESS troubleshooting I have found a solution. A ridiculous, counter-intuitive solution, but a solution nonetheless.

Like so many others, I had been unable to run Shogun 2 on my Windows 10 laptop. It would get to the splash screen, the mouse would change to a yari, but then the splash screen would disappear without even an error message.

I tried everything but in the end this worked. The solution was right under my nose the whole time.

If you've been looking up this problem, you've probably come across someone saying they fixed it by uninstalling McAfee WebAdvisor.

Now, you may not have McAfee WebAdvisor. You might have scoured your computer for it seeing if it was hiding a file or two somewhere, but nothing. That couldn't be the problem. So you tried everything you could to no avail.

But that IS the solution. But in order to UNINSTALL McAfee WebAdvisor, you have to INSTALL IT first. I'm serious.

1. Install McAfee WebAdvisor. Yes really.
2. Run the game. It will fail as usual. I don't know if this step is necessary but it's what I did.
3. Uninstall McAfee WebAdvisor.
4. Run the game.

Where everything else failed, this worked. Shogun 2 now runs beautifully for me.

Comments

Sign In or Register to comment.