Welcome

Please register for Total War Access to use the forums. If you're an existing user, your forum details will be merged with Total War Access if you register with the same email or username. For more information please read our FAQ’s here.

Categories

In ProgressCan't load into multiplayer battles.

mte0912mte0912 Posts: 1Registered Users
edited October 10 in Multiplayer Bugs
Me and a friend have been playing warhammer 2 for some time now but recently we have had problems with battles. The game just tells us that its waiting for the other player to load even though we are both loaded. This is true for both the campaign agains AI and versus battles. Does anyone have a solution to this problem?
Post edited by CA_Vix on

Comments

  • CA_VixCA_Vix Posts: 211Registered Users, Moderators, CA Staff Mods, CA Staff
    mte0912 said:

    Me and a friend have been playing warhammer 2 for some time now but recently we have had problems with battles. The game just tells us that its waiting for the other player to load even though we are both loaded. This is true for both the campaign agains AI and versus battles. Does anyone have a solution to this problem?

    Hi there,

    We've just released a beta update that may resolve your issue!

    Details on what fixes we've made and how to access the beta can be found here: https://www.totalwar.com/blog/total-war-warhammer-ii-patch-beta/

    All the best,

    Vix

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file