Welcome

Please register for Total War Access to use the forums. If you're an existing user, your forum details will be merged with Total War Access if you register with the same email or username. For more information please read our FAQ’s here.

Categories

Launcher do not launch the game

KirkannosKirkannos Posts: 4Registered Users
Hello,

I bought Warhammer 2 yesterday and I still trying to launch it. Whenever I start the game, steam is launched and then appears Totalwar launcher. When I press start, the launcher closes and that's it. I tried to get the launcher beta on steam it didn't help (maybe after I restart my computer) I know that I should provide the preference.script but this file doesn't exist in my "appdata/roaming/The creative Assembly" folder I only have a launcher folder here.

I hope you can give me a solution

Cheers

PS : I went through tons of solution on the internet the very few I could test didn't work. I can not test the remaining solutions since I have not the same structure in the "appdata/roaming/The creative Assembly" folder

Comments

  • saltymelonfiresaltymelonfire Posts: 3Registered Users
    Exact same issue here, and a friend of mine too.

    Up! :)
  • KirkannosKirkannos Posts: 4Registered Users
    Has the support read this discussion ? could you please at least post something to acknowledge that you read ?
  • BillyRuffianBillyRuffian Moderator UKPosts: 36,085Registered Users, Moderators, Knights
    edited October 26
    Try clearing your Steam download cache then deleting the Launcher folder.

    Also you should do a custom clean install of your Nvidia driver directly from their site, and it may be worth disabling your Daemon Tools software.

    Edit: are you sure the game is set to show on your main screen?
    Post edited by BillyRuffian on

    "He uses statistics as a drunken man uses lamp-posts - for support rather than illumination." (Andrew Lang)

    |Takeda| Yokota Takatoshi

    Forum Terms and Conditions: - https://forums.totalwar.com/discussion/172193/forum-terms-and-conditions#latest

    "We wunt be druv". iot6pc7dn8qs.png
  • KirkannosKirkannos Posts: 4Registered Users
    It still didn't work. After i click play on the CA launcher, the launcher close and that 's it. The steam launcher wich was considering I was playing stop as well to consider Warhammer II to be an active game. What else could I do ?
  • saltymelonfiresaltymelonfire Posts: 3Registered Users
    edited October 27
    I figured a solution on my own.

    It realy sounds like we have the same issue, try this @Kirkannos

    Go to your launcher folder (C/windows/system32/config/systemprofile/AppData/Local/)

    !! You may have to cheat a bit to actually access the "System32" file. If so, try to Window+R and copy-paste the way.
    If you get a error message, try to only search for "system32". If you still get an error message, you must apply the next advice from the "C/windows/" folder to actually access to the folder.)


    First, check if you can SEE the folder "TileDataLayer" (This is the actual launcher folder).

    If you don't see it ->

    First, you'll have to toggle on the "Show hidden files" option. (Being french the wording wont be the same as yours,
    but the location is basicly the same, otherwise, Google it.)





    Try to open it.


    If you can -> Go to step 2.


    If you can't, -> that mean you have the exact same problem. (This is due to windows defender BTW, kisses to our beloved CM)

    Step 1 You'll have to update your administrator rights on windows files. i'll let you looking for it, as i'm not an expert :)




    (You have to set YOUR personnal/administrator windows account into owner ("propriétaire" in my screenshot.)

    Now you should be able to open the folder "TileDataLayer".


    Step 2 Close steam, Delete the "TileDataLayer" folder, and then launch WarHammer2.

    Step 3 Enjoy the game! :D


    @BillyRuffian As the issue come directly from windows defender, even re-installing STEAM (and so all solution related to its support service) wont work. Hope you can redirect people to this post, it may saves some time/money :D .
  • saltymelonfiresaltymelonfire Posts: 3Registered Users
    I wrote a realy long tuto, turns out my connexion crashed.
    Here is the oversimplyfied version.

    Press Windows+R

    Look for "C:\Windows\System32\config\systemprofile\AppData\Local"

    - If it doesn't work, try "System32"

    If you still have an error message, go on your "C:\Windows\" folder, oppen the "Appearence" menue on the top of your window, and ennable the "Show Hidden folders" option.



    Now go manualy through folders to the "C:\Windows\System32\config\systemprofile\AppData\Local".

    Check if you can SEE the "TileDataLayer" folder (actual launcher folder)

    If you can see it, close steam, Delete it, launch the game, press play, enjoy the game.

    IF you CAN'T see it.

    you must change the owner of the folder from "system" to you actual adminstrator windows account


    Once it's done, you should be abble to close steam, Delete the "TileDateLayer" folder, launch the game, press play, enjoy the game

    @BillyRuffian This issue being due to windows defender, using Steam's interface or even unistall steam won't work (I even tryed to reset my pc.)

  • KirkannosKirkannos Posts: 4Registered Users
    Thank you for your concern Saltymelonfire (Since I'm french too I haven't any problem to follow youre tutorial). However, after I access C:/windows/system32/config/systemprofile/AppData/Local/ (with the addition of the ":" comparing to your path :smile: ) I cannot found the TileDataLayer folder even after authorizing to show hidden files.



    My OS is window 7 though so maybe this is the problem here ? En tout cas, amuse toi bien ^^

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file