Welcome

Please register for Total War Access to use the forums. If you're an existing user, your forum details will be merged with Total War Access if you register with the same email or username. For more information please read our FAQ’s here.

Categories

Crashes on 20% loading

GrayserGrayser Junior MemberRegistered Users Posts: 314
I currently have two DE and one HE campaign stuck due to this, my Skaven and Repanse campaign worked fine but now the game just derps out for a lack of a better term.

I use cosmetics mods sorted via a mod manager to avoid conflicts.

I have already tried running clean non-modded game, I have also reinstalled steam.

I realise its the holidays but please sort this as every campaign is a ticking time bomb before it goes tits up.

Again I realise its the holidays so happy holidays and I hope you can get this sorted.
«1

Comments

  • yossrian22yossrian22 Registered Users Posts: 1
    This happening to me too. I’ve tried three skaven campaigns and all three get to a point where the game eventually crashes I loading a save. I got to turn 30,42 and 172 before each of my ME campaigns playing skaven before the game just endlessly crashes on reloading saves.
  • Lampros73Lampros73 Registered Users Posts: 158
    This is indeed the very bug I am experiencing - as well as many folks on Steam I talk to who own Warhammer 2.
  • GrayserGrayser Junior Member Registered Users Posts: 314
    Just hope it can get hotfixed, but if everyones on vaccation it might be a solid wait until its sorted.

    Hoping for the best as the game is currently unplayable, quite literally.
  • Lampros73Lampros73 Registered Users Posts: 158
    Grayser said:

    Just hope it can get hotfixed, but if everyones on vaccation it might be a solid wait until its sorted.

    Hoping for the best as the game is currently unplayable, quite literally.

    Indeed. And it says volumes about CA's quality of life team that something like this can slip through...
  • GrayserGrayser Junior Member Registered Users Posts: 314
    For me its occured during settlement/siege battles only, is it the same for you guys?
  • BillyRuffianBillyRuffian Moderator UKRegistered Users, Moderators, Knights Posts: 39,414

    "He uses statistics as a drunken man uses lamp-posts - for support rather than illumination." (Andrew Lang)

    |Takeda| Yokota Takatoshi

    Forum Terms and Conditions: - https://forums.totalwar.com/discussion/172193/forum-terms-and-conditions#latest

    "We wunt be druv". iot6pc7dn8qs.png
  • GrayserGrayser Junior Member Registered Users Posts: 314
    Yeh tried most of these already, honestly at this point I am just playing other games until this gets fixed.

    Spending hour(s) trying to get a save game to load feels slightly wasted when I see a fair amount of people running into the same issue.

    Might try some stuff again but will probably just wait it out.

    Thanks for the tips and links though.
  • Lampros73Lampros73 Registered Users Posts: 158
    Grayser said:

    For me its occured during settlement/siege battles only, is it the same for you guys?

    Primarily during battles but occasionally during end turn AI activities.
  • Lampros73Lampros73 Registered Users Posts: 158
    Grayser said:

    Yeh tried most of these already, honestly at this point I am just playing other games until this gets fixed.

    Spending hour(s) trying to get a save game to load feels slightly wasted when I see a fair amount of people running into the same issue.

    Might try some stuff again but will probably just wait it out.

    Thanks for the tips and links though.

    Same here. The campaign is currently unplayable, as the corruption bug will ultimately hit always.
  • BillyRuffianBillyRuffian Moderator UKRegistered Users, Moderators, Knights Posts: 39,414
    Grayser said:

    Yeh tried most of these already, honestly at this point I am just playing other games until this gets fixed.

    Spending hour(s) trying to get a save game to load feels slightly wasted when I see a fair amount of people running into the same issue.

    Might try some stuff again but will probably just wait it out.

    Thanks for the tips and links though.

    The best thing t odo, then, is to provide the information CA will need to identify and resolve the cause https://forums.totalwar.com/discussion/202015/read-this-before-posting.

    "He uses statistics as a drunken man uses lamp-posts - for support rather than illumination." (Andrew Lang)

    |Takeda| Yokota Takatoshi

    Forum Terms and Conditions: - https://forums.totalwar.com/discussion/172193/forum-terms-and-conditions#latest

    "We wunt be druv". iot6pc7dn8qs.png
  • LaindeshLaindesh Junior Member Registered Users Posts: 3,491
    I get the same thing, Playing the game is fine, no crashing.

    First 80 turns is also fine at saving usually. Its after that the save fails to load the game.
    Crashing at 20%~ everytime.

    Happened with Every faction i've played with so far. I am updating drivers, cleaning folders etc. So will post a proper bug report with info if it hits again
  • akakevinakakevin Registered Users Posts: 3
    I'm experiencing the same problem as the OP also.
  • eterna24eterna24 Registered Users Posts: 7
    Same here. I've tried reinstalling Steam and TW:W2 to no effect.

    Initial crashes happened at turn ~100 on Malekith Vortex campaign during AI turns and turn ~60 Repanse Vortex campaign after a manual battle.

    Most of the loads are corrupted and always crash at 20%.
  • FiftyTiftyFiftyTifty Registered Users Posts: 58
    I've posted about the same issue, replete with saves and collection of the mods used in them. The Steam forum thread about the 1.8.1 update is also filled with people reporting the same issue: https://steamcommunity.com/app/594570/discussions/0/1743388044203764664/?ctp=8
  • GrayserGrayser Junior Member Registered Users Posts: 314
    edited December 2019
    I might load up one of my crash saves when I get home from work today which at this point is all but two.

    But is anyone even at CA to fix this? With holidays and all.

    What I mean is this, I can post files out the whasoo but if there is no one at the office its slightly pointless.

    As most people here, I have job as well, and its not to bugtest and fix a product I have already paid for.

    Dunno how generous the vaccations are in the UK but this is the sort of thing that someone should come have a proper look at and maybe even acknowledge as a real issue.
    Post edited by Grayser on
  • eterna24eterna24 Registered Users Posts: 7
    edited December 2019
    eterna24 said:

    Same here. I've tried reinstalling Steam and TW:W2 to no effect.

    Initial crashes happened at turn ~100 on Malekith Vortex campaign during AI turns and turn ~60 Repanse Vortex campaign after a manual battle.

    Most of the loads are corrupted and always crash at 20%.

    Guys, let's try to help them out at least. It'll only help them debug faster.

    Here's my upload - I can provide more examples if needed.

    Build v1.8.1
    13089.1833768 (modded)
  • Lampros73Lampros73 Registered Users Posts: 158
    eterna24 said:

    eterna24 said:

    Same here. I've tried reinstalling Steam and TW:W2 to no effect.

    Initial crashes happened at turn ~100 on Malekith Vortex campaign during AI turns and turn ~60 Repanse Vortex campaign after a manual battle.

    Most of the loads are corrupted and always crash at 20%.

    Guys, let's try to help them out at least. It'll only help them debug faster.

    Here's my upload - I can provide more examples if needed.

    Build v1.8.1
    13089.1833768 (modded)
    I doubt this will get fixed until well after New Year. Everyone's probably on holidays.

    This really sucks.
  • eterna24eterna24 Registered Users Posts: 7
    edited December 2019
    Lampros73 said:

    eterna24 said:

    eterna24 said:

    Same here. I've tried reinstalling Steam and TW:W2 to no effect.

    Initial crashes happened at turn ~100 on Malekith Vortex campaign during AI turns and turn ~60 Repanse Vortex campaign after a manual battle.

    Most of the loads are corrupted and always crash at 20%.

    Guys, let's try to help them out at least. It'll only help them debug faster.

    Here's my upload - I can provide more examples if needed.

    Build v1.8.1
    13089.1833768 (modded)
    I doubt this will get fixed until well after New Year. Everyone's probably on holidays.

    This really sucks.
    I'm thinking about rolling back the game version to 1.7.2 for the holidays or until this issue is resolved.

    If you have it on Steam, right-click the game > Properties > Betas > warhammerii_1.7.2

    I'll let you all know if I run into the same issue.

    edit: Just to be clear, I tried this yesterday and the 1.8.1 save files still CTD on load; but if you start a new 1.7.2 campaign the save files should be fine as you progress. Hope that helps salvage a bit of your Holidays ;)
  • Lampros73Lampros73 Registered Users Posts: 158
    eterna24 said:



    I'm thinking about rolling back the game version to 1.7.2 for the holidays or until this issue is resolved.

    If you have it on Steam, right-click the game > Properties > Betas > warhammerii_1.7.2

    I'll let you all know if I run into the same issue.

    edit: Just to be clear, I tried this yesterday and the 1.8.1 save files still CTD on load; but if you start a new 1.7.2 campaign the save files should be fine as you progress. Hope that helps salvage a bit of your Holidays ;)

    But then we'd be without the improved turn times, no? After having experienced airplane travel, I certainly don't want to use walk anywhere any more! ;)
  • eterna24eterna24 Registered Users Posts: 7
    edited December 2019
    Lampros73 said:

    eterna24 said:



    I'm thinking about rolling back the game version to 1.7.2 for the holidays or until this issue is resolved.

    If you have it on Steam, right-click the game > Properties > Betas > warhammerii_1.7.2

    I'll let you all know if I run into the same issue.

    edit: Just to be clear, I tried this yesterday and the 1.8.1 save files still CTD on load; but if you start a new 1.7.2 campaign the save files should be fine as you progress. Hope that helps salvage a bit of your Holidays ;)

    But then we'd be without the improved turn times, no? After having experienced airplane travel, I certainly don't want to use walk anywhere any more! ;)
    I'll take slow Repanse over no Repanse :'(

    edit: crap... Repanse was introduced in 1.8.1...
  • Lampros73Lampros73 Registered Users Posts: 158
    eterna24 said:


    I'll take slow Repanse over no Repanse :'(

    edit: crap... Repanse was introduced in 1.8.1...


    ROFL ;)
  • FreelancerlpFreelancerlp Junior Member Registered Users Posts: 3
    Hey,

    My Legendary Snikch Mortal Empires Campaign Crashes on the end-turn calculation of turn 173 (Averland Crashes).
    During this turn I have triggered the Anarchy mechanic killing the huge dwarven empire.

    I am litteraly 6 Tech-Units short of wining the short-campaign victory ~_~.

    Build: 1.8.1
    13089.1833768 (modded) Allthough no Mods are activated. Files have been attached.
  • GrayserGrayser Junior Member Registered Users Posts: 314
    Sent my saves to a friend and they are corrupted for him as well.

    Ill post as many logs and files as you want, just one thing.

    Is anyone home? a simple yes from someone from CA surely isent to much to ask for.

    Yes

    Took me all of 2 seconds

    I have also verified my drives, ran a sfc /scannow on my C:Drive and still issues.
  • eterna24eterna24 Registered Users Posts: 7
    I can confirm that my 1.7.2 rollback is saving without issues, so it does appear to be an issue with 1.8.1 and 1.8.2.
  • Lampros73Lampros73 Registered Users Posts: 158
    eterna24 said:

    I can confirm that my 1.7.2 rollback is saving without issues, so it does appear to be an issue with 1.8.1 and 1.8.2.


    Could you post this on https://steamcommunity.com/app/594570/discussions/0/1743388044203764664/ as well?

    It's a very relevant piece of information.
  • eterna24eterna24 Registered Users Posts: 7
    Lampros73 said:

    eterna24 said:

    I can confirm that my 1.7.2 rollback is saving without issues, so it does appear to be an issue with 1.8.1 and 1.8.2.


    Could you post this on https://steamcommunity.com/app/594570/discussions/0/1743388044203764664/ as well?

    It's a very relevant piece of information.
    Done!
  • Lampros73Lampros73 Registered Users Posts: 158
    eterna24 said:

    Lampros73 said:

    eterna24 said:

    I can confirm that my 1.7.2 rollback is saving without issues, so it does appear to be an issue with 1.8.1 and 1.8.2.


    Could you post this on https://steamcommunity.com/app/594570/discussions/0/1743388044203764664/ as well?

    It's a very relevant piece of information.
    Done!
    I just saw; thanks!
  • GrayserGrayser Junior Member Registered Users Posts: 314
    Stupid question but rolling back removes Repanse, Malus, Snitch and turn times right?
  • FiftyTiftyFiftyTifty Registered Users Posts: 58
    Yeah, you lose all the added DLC stuff, the fixes, and the turn time improvements.
  • GrayserGrayser Junior Member Registered Users Posts: 314
    Guess ill wait for CA to acknowledge the issue before I can play this again then I guess.

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file