Welcome

Please register for Total War Access to use the forums. If you're an existing user, your forum details will be merged with Total War Access if you register with the same email or username. For more information please read our FAQ’s here.

Categories

Crashing on startup

VelveVelve Registered Users Posts: 8
Build: Not sure. The game crashes too early to see. It's the latest patch as of posting, the Potion of Speed Update. I own all the DLC besides the Call of the Beastmen for Warhammer 1.

Detailed description:
Not much to detail. Since the last update, I had been able to play fine, first without mods, then with mods. Abruptly on about 23rd December the game began loading the initial title screen... Then goes to a black screen, then crashes to desktop.

Reproduction Steps:
-Start game
-Look at title screen for 10 seconds as it tries to load
-Crash?

Not sure what reproduction steps really means so, sorry I can't help much.


Details of any solutions that have already been attempted:
I've updated my graphics drivers, deleted all my mods, completely deleted and reinstalled the game (Though not WH1), verified the game and restarted the PC between pretty much every step.

Hopefully I got all the attached files right. Let me know if there's anything else needed. Hopefully someone can help me. Thanks!

Comments

  • VelveVelve Registered Users Posts: 8
    As an update, I've retried all the things about half a dozen times over the past few days. I tried disabling all the DLC and playing the base game alone, same result. Warhammer 1 works, for what little it's worth, but exactly the same with warhammer 2, loads up title screen, about 10-20 seconds later, just ctd with no messages or anything.

    Any new ideas to try would really be appreciated, I'm missing one of my favourite games.
  • Lampros73Lampros73 Registered Users Posts: 158
    Velve said:

    As an update, I've retried all the things about half a dozen times over the past few days. I tried disabling all the DLC and playing the base game alone, same result. Warhammer 1 works, for what little it's worth, but exactly the same with warhammer 2, loads up title screen, about 10-20 seconds later, just ctd with no messages or anything.

    Any new ideas to try would really be appreciated, I'm missing one of my favourite games.

    It's a vanilla bug. CA will need to fix it.
  • VelveVelve Registered Users Posts: 8
    A vanilla bug? You mean this issue has been going on for some people since launch?

    I've never had the problem before.
  • Lampros73Lampros73 Registered Users Posts: 158
    Velve said:

    A vanilla bug? You mean this issue has been going on for some people since launch?

    I've never had the problem before.

    It's a bug introduced with the current DLC/update. Several folks have isolated it, and it's apparently a threadding issue.
  • VelveVelve Registered Users Posts: 8
    Ah, alright that makes some sense. I'd been playing the game several days on the current update before it happened but guess it can still happen.

    Thanks. Just have to hope it gets fixed soon.
  • FiftyTiftyFiftyTifty Registered Users Posts: 59
    The instruction shown in your crash is different than everyone else's. I'll make note of that in the ticket:

    CONTEXT: (.ecxr)
    rax=0000000000000000 rbx=0000000142ddd6c0 rcx=0000000000000000
    rdx=0000000000000000 rsi=00000000ffffffff rdi=000000000014e9a0
    rip=00007ff978dc9159 rsp=000000000014e830 rbp=000000000014e970
    r8=0000000000000000 r9=0000000000000000 r10=0000000000000000
    r11=0000000000000000 r12=0000000142ee72b0 r13=0000000000000000
    r14=0000000000000676 r15=000000001b6fb110
    iopl=0 nv up ei pl nz na po nc
    cs=0033 ss=002b ds=002b es=002b fs=0053 gs=002b efl=00000206
    KERNELBASE!RaiseException+0x69:
    00007ff9`78dc9159 0f1f440000 nop dword ptr [rax+rax]
    Resetting default scope

    FAULTING_IP:
    KERNELBASE!RaiseException+69
    00007ff9`78dc9159 0f1f440000 nop dword ptr [rax+rax]

    EXCEPTION_RECORD: (.exr -1)
    ExceptionAddress: 00007ff978dc9159 (KERNELBASE!RaiseException+0x0000000000000069)
    ExceptionCode: e06d7363 (C++ EH exception)
    ExceptionFlags: 00000001
    NumberParameters: 4
    Parameter[0]: 0000000019930520
    Parameter[1]: 000000000014e9a0
    Parameter[2]: 0000000142ddd6c0
    Parameter[3]: 0000000140000000
  • VelveVelve Registered Users Posts: 8
    Sorry, I'm not sure I understand. Is that something I can fix...? Is it just that mine's seemingly caused by something else but still not anything I can do to fix it?
  • SiosmSiosm Registered Users Posts: 2
    Hi,

    I have a similar issue: when I start the game I get a black screen (no logo), and about 30 seconds after that the game crashes to desktop.

    I have tried all the steps to verify game files, reinstalled from scratch, removed all folders in AppData/Roaming, etc.

    Attached are a DxDiag & minidump. Here is the analysis from WinDbg for the dump:

    CONTEXT: (.ecxr)
    rax=000000000fc20b38 rbx=0000000000000000 rcx=0000000000000000
    rdx=000000000fa3aed8 rsi=0000000000000000 rdi=0000000000100000
    rip=0000000147826ddb rsp=000000000014e2f0 rbp=000000000014e450
    r8=0000000000000000 r9=0000000000000002 r10=000000000014e320
    r11=0000000000000000 r12=00000000344a5b70 r13=0000000000000001
    r14=0000000000000000 r15=0000000025b24240
    iopl=0 nv up ei pl nz na pe nc
    cs=0033 ss=002b ds=002b es=002b fs=0053 gs=002b efl=00010202
    Warhammer2!destroy+0x110ee2b:
    00000001`47826ddb 488b01 mov rax,qword ptr [rcx] ds:00000000`00000000=????????????????
    Resetting default scope

    EXCEPTION_RECORD: (.exr -1)
    ExceptionAddress: 0000000147826ddb (Warhammer2!destroy+0x000000000110ee2b)
    ExceptionCode: c0000005 (Access violation)
    ExceptionFlags: 00000000
    NumberParameters: 2
    Parameter[0]: 0000000000000000
    Parameter[1]: 0000000000000000
    Attempt to read from address 0000000000000000

    PROCESS_NAME: Warhammer2.exe

    READ_ADDRESS: 0000000000000000

    ERROR_CODE: (NTSTATUS) 0xc0000005 - The instruction at 0x%p referenced memory at 0x%p. The memory could not be %s.

    EXCEPTION_CODE_STR: c0000005

    EXCEPTION_PARAMETER1: 0000000000000000

    EXCEPTION_PARAMETER2: 0000000000000000

    STACK_TEXT:
    00000000`0014e2f0 00000001`424de586 : 00000000`25b24240 00000000`00010000 00000000`00000001 00000001`00000001 : Warhammer2!destroy+0x110ee2b
    00000000`0014e350 00000001`4254b367 : 00000000`1c76b530 00000000`00000000 00000000`00000000 00000000`00000000 : Warhammer2!show_objective+0x5459d6
    00000000`0014e490 00000001`42588670 : 00000000`00000001 00000000`0014e5c9 00000000`02000080 00000000`00000000 : Warhammer2!show_objective+0x5b27b7
    00000000`0014e4e0 00000001`4267f22c : 00000000`0257e1a2 00000000`25b24060 00000000`00000001 00000000`00000000 : Warhammer2!show_objective+0x5efac0
    00000000`0014e610 00000001`425446b4 : 00000000`2b5fbb30 00000000`00000000 00000000`00000000 00000000`00000000 : Warhammer2!show_objective+0x6e667c
    00000000`0014e7e0 00000001`47846be1 : 0000001c`00000035 00000000`0fc20b38 00007ff4`fd2b0010 00000000`113290a0 : Warhammer2!show_objective+0x5abb04
    00000000`0014e870 00000001`401fba5e : 00000000`11332720 00000000`0014e9e0 00000000`11332720 00000000`00000000 : Warhammer2!destroy+0x112ec31
    00000000`0014e8a0 00000001`4020194d : 00000000`0000003c 00007ffe`3c3c305d 00000000`ffffffff 00000000`00000000 : Warhammer2!make_fiber+0x1cb4e
    00000000`0014e8e0 00000001`401fe8f8 : 00000000`0000003c 00000001`00000000 00000000`00000000 00000000`00000000 : Warhammer2!make_fiber+0x22a3d
    00000000`0014ea60 00000001`4020350e : 00000001`40000000 00000000`004a38aa 00000001`40000000 00000000`0014eb68 : Warhammer2!make_fiber+0x1f9e8
    00000000`0014eb20 00000001`401f2e08 : 00000000`00000000 00000000`004a38aa 00000000`041d1b08 00000000`00000000 : Warhammer2!make_fiber+0x245fe
    00000000`0014f570 00000001`40192194 : 00000000`00000000 00000000`00000000 00000001`435fcfe8 00000001`00000001 : Warhammer2!make_fiber+0x13ef8
    00000000`0014fdf0 00000001`427b11a4 : 00000000`00000000 00000000`00000000 00000000`0000000a 00000001`40000000 : Warhammer2+0x192194
    00000000`0014fef0 00007ffe`3fc67bd4 : 00000000`00000000 00000000`00000000 00000000`00000000 00007ffd`f3ea0000 : Warhammer2!show_objective+0x8185f4
    00000000`0014ff30 00007ffe`3fdcced1 : 00000000`00000000 00000000`00000000 00000000`00000000 00000000`00000000 : kernel32!BaseThreadInitThunk+0x14
    00000000`0014ff60 00000000`00000000 : 00000000`00000000 00000000`00000000 00000000`00000000 00000000`00000000 : ntdll!RtlUserThreadStart+0x21


    SYMBOL_NAME: Warhammer2!destroy+110ee2b

    MODULE_NAME: Warhammer2

    IMAGE_NAME: Warhammer2.exe

    STACK_COMMAND: ~0s ; .ecxr ; kb

    FAILURE_BUCKET_ID: NULL_POINTER_READ_c0000005_Warhammer2.exe!destroy

    OS_VERSION: 10.0.18362.1

    BUILDLAB_STR: 19h1_release

    OSPLATFORM_TYPE: x64

    OSNAME: Windows 10

    FAILURE_ID_HASH: {8054a334-8864-c23d-8111-6c703be80216}


    Thanks
  • RavossRavoss Registered Users Posts: 1
    Hi, i have the same Problem since the last dlc update.
    I just tried the 1.8.3 beta patch and updated my graphics drivers.
    I have tried all the steps to verify game files, reinstalled from scratch, removed all folders in AppData/Roaming.

    Other TotalWar Games, like Three Kingdoms are working fine.
  • SiosmSiosm Registered Users Posts: 2
    This is fixed for me with the current path / release! Thanks a lot!
  • VelveVelve Registered Users Posts: 8
    Sadly, this is still occuring. Still updated the game several times, updated drivers several times, and completely reinstalled several times, intermittedly trying to launch the game. Still crashes the exact same way. I'm extraordinarily annoyed, because I love this game so bloody much, but I haven't been able to so much as look at the main menue in MONTHS, and for all I can tell it's nothing I've done/not done.

    At this rate I'll be waiting until game 3 before I can play again... If then...

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file