Please register for Total War Access to use the forums. If you're an existing user, your forum details will be merged with Total War Access if you register with the same email or username. For more information please read our FAQ’s here.


New Campaign Crashes Every time

Oliver9518Oliver9518 Registered Users Posts: 3
edited January 2020 in Crashes
Hi, all

Recently bought Warhammer 2 and have tried to start a few campaigns for the first time but the game crashes to desktop every time. I've exhausted many of the support options (https://support.sega.co.uk/hc/en-us/articles/360001559217-GAME-CRASHES-WON-T-WORK-WON-T-LAUNCH) to no avail.

Warhammer 1 works fine on ultra setting and can play all other aspects of 2 on high but whenever I try to start a ME or Vortex campaign it loads just before the bar fills then crashes.

Been reading that other people have been having a similar problem in the past few days so was wondering if this isn't just an isolated issue. Would appreciate any advice/suggestions.


EDIT: To help troubleshoot have attached requested info.

Post edited by Oliver9518 on


  • FiftyTiftyFiftyTifty Registered Users Posts: 58
    edited January 2020
    What's causing your crash is not the same as everyone else's:

    CONTEXT: (.ecxr)
    rax=0000000000000000 rbx=0000000000000000 rcx=000000000014e4c0
    rdx=0000000000000001 rsi=000000005975b850 rdi=000000000f92a168
    rip=00000001427445b7 rsp=000000000014e460 rbp=000000000014e4e9
    r8=00000000d569ad68 r9=0000000000000000 r10=0000000000000000
    r11=0000000000000246 r12=0000000000000000 r13=0000000000000000
    r14=0000000000000000 r15=0000000000000000
    iopl=0 nv up ei pl zr na po nc
    cs=0033 ss=002b ds=002b es=002b fs=0053 gs=002b efl=00010246
    00000001`427445b7 4c8b10 mov r10,qword ptr [rax] ds:00000000`00000000=????????????????
    Resetting default scope

    00000001`427445b7 4c8b10 mov r10,qword ptr [rax]

    EXCEPTION_RECORD: (.exr -1)
    ExceptionAddress: 00000001427445b7 (Warhammer2+0x00000000027445b7)
    ExceptionCode: c0000005 (Access violation)
    ExceptionFlags: 00000000
    NumberParameters: 2
    Parameter[0]: 0000000000000000
    Parameter[1]: 0000000000000000
    Attempt to read from address 0000000000000000

    BUGCHECK_STR: 99CA0526



    FAULTING_MODULE: 00007ff8a0380000 ntdll


    Are you using any mods?

    Also, you're using Direct3D 12. NVidia's support for it is pretty much broken on pre-1000 series GPUs, so try using Direct3D 11 instead.
  • Oliver9518Oliver9518 Registered Users Posts: 3

    Thanks for the quick response. Nope I'm just running vanilla at the moment. I've checked under advanced graphic options and it says I'm running DirectX 11, is this the same thing? Or is Direct3D 12 changed within Nvidia's control panel?

    Thanks again,

  • FiftyTiftyFiftyTifty Registered Users Posts: 58
    Then you'll be running Direct3D 11, my bad. Dxdiag said you had Direct3D 12, but that's the maximum supported version rather than what was in use.

    Try switching to Direct3D 12 to see if it makes any difference.
  • Oliver9518Oliver9518 Registered Users Posts: 3
    No worries. Have tried running Directx12 but also crashed, it's very frustrating. Can't even run campaign benchmark without the game crashing to desktop. At this point I feel like hoping a patch will solve the issue is the only route.

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file