Welcome

Please register for Total War Access to use the forums. If you're an existing user, your forum details will be merged with Total War Access if you register with the same email or username. For more information please read our FAQ’s here.

Categories

Saves keep corrupting since the last patch

13»

Comments

  • LewyoneLewyone Junior Member Registered Users Posts: 9
    So I tested with only Execute Lords and Heroes mod enabled , 100 turns as Malekith and no corruption to saves. But keep in mind i tested updated version of this mod from 10.01. ( which author updated to prevent corruption to saves) and no manual battles . I will check if i Have previous version of this mod. How is your testing going?
  • Lampros73Lampros73 Registered Users Posts: 158
    Lewyone said:

    So I tested with only Execute Lords and Heroes mod enabled , 100 turns as Malekith and no corruption to saves. But keep in mind i tested updated version of this mod from 10.01. ( which author updated to prevent corruption to saves) and no manual battles . I will check if i Have previous version of this mod. How is your testing going?

    If you are not having manual battles, then I think the test is not as useful. I believe the corruption only occurs after manual battles?
  • Lampros73Lampros73 Registered Users Posts: 158
    Strats121 said:

    @FiftyTifty & @Lampros73 Have we had an update from the developers yet?

    Don't know, but someone on the other forum claimed that a dev said on Reddit that this was a mod issue, not a vanilla issue.
  • FiftyTiftyFiftyTifty Registered Users Posts: 58
    @Lewyone Turn 40 so far, but you really ought to use manual battles, as that is the end result of the bug; CTD as the post-battle load screen reaches 20%.

    @Strats121 No response from the ticket unfortunately.

    @Lampros73 Yeh we saw that the battles played a part, as you would reach a point where you would crash after fighting any battle manually.
  • Lampros73Lampros73 Registered Users Posts: 158
    I have a few hours now, so I will see what happens if I just get rid of Execute (useless) Lords.

    I am also wondering if there is a possibility that if this issue is faction-specific or happens more often with a particular faction.

    For instance, with Empire it happens very early - inside 30 turns every time except one occasion. Yet, I just played up to 300 turns with Skaven. But it could also be that I try to avoid manual combat with Skaven, since I am not good with them and take as much casualties as I would in auto anyways.
  • vonKukisvonKukis Registered Users Posts: 6
    Lampros73 said:

    I have a few hours now, so I will see what happens if I just get rid of Execute (useless) Lords.

    I am also wondering if there is a possibility that if this issue is faction-specific or happens more often with a particular faction.

    For instance, with Empire it happens very early - inside 30 turns every time except one occasion. Yet, I just played up to 300 turns with Skaven. But it could also be that I try to avoid manual combat with Skaven, since I am not good with them and take as much casualties as I would in auto anyways.

    Yesterday i did play with 'Execute Lords' mod turned off, all others I'm using were left on. I started with 101 turn, very hard Repanse, Vortex campaign, finished at turn 135. Previously I could progress no further than turn 103 and all saves since 101 manual save were corrupted, plus every single manual battle did end with CTD.
    After turning 'Execute Lords' off, I DID NOT encounter a single corrupted save, both manual and autosaves. I also did play a couple of battles - no CTD.

    Still, if I capture a single town (Bhagar in Shifting Sands region to be exact, controlled by Tomb Kings Rebels), suddenly 100% saves since that moment became corrupted and every single manual battle ended with CTD. Tested in different turns, corruption always happened after conquering the city. But leaving the settlement alone allowed me to progress further on without any corrupted saves.
  • Lampros73Lampros73 Registered Users Posts: 158
    vonKukis said:

    Lampros73 said:

    I have a few hours now, so I will see what happens if I just get rid of Execute (useless) Lords.

    I am also wondering if there is a possibility that if this issue is faction-specific or happens more often with a particular faction.

    For instance, with Empire it happens very early - inside 30 turns every time except one occasion. Yet, I just played up to 300 turns with Skaven. But it could also be that I try to avoid manual combat with Skaven, since I am not good with them and take as much casualties as I would in auto anyways.

    Yesterday i did play with 'Execute Lords' mod turned off, all others I'm using were left on. I started with 101 turn, very hard Repanse, Vortex campaign, finished at turn 135. Previously I could progress no further than turn 103 and all saves since 101 manual save were corrupted, plus every single manual battle did end with CTD.
    After turning 'Execute Lords' off, I DID NOT encounter a single corrupted save, both manual and autosaves. I also did play a couple of battles - no CTD.

    Still, if I capture a single town (Bhagar in Shifting Sands region to be exact, controlled by Tomb Kings Rebels), suddenly 100% saves since that moment became corrupted and every single manual battle ended with CTD. Tested in different turns, corruption always happened after conquering the city. But leaving the settlement alone allowed me to progress further on without any corrupted saves.
    Weird. So capturing other towns did not cause a crash but only Bhagar?
  • Lampros73Lampros73 Registered Users Posts: 158
    By the way, should you not start a fresh game to test?
  • vonKukisvonKukis Registered Users Posts: 6
    Lampros73 said:

    By the way, should you not start a fresh game to test?

    TBH I only had an hour or two to play, plus this was already the hardest campaign I have played so far (including a couple of legendary ones) and I really didn't want to lose those 100 turns (and start from scratch). One one hand, starting fresh is probably the best approach, but on the other - now we know that corrupted campaigns are at least recoverable.

    And yes, capturing other towns did nothing, but conquering Bhagar ended in saves corruption every single time.
  • WitchbladeWitchblade Registered Users Posts: 950
    Today's update also caused saved multiplayer armies to be unable to load. Many armies that worked fine this patch now cannot be loaded anymore. They show the error 'too many units of a certain type', yet they worked before and when I load them in custom battle, they don't violate the Unit Caps restriction.
  • vonKukisvonKukis Registered Users Posts: 6
    @Lampros73, I did play 2 campaigns last week:
    First one totally clear, no mods whatsoever, 120 turns, no save corrupted.
    Second one, all mods turned on (but not "Execute Lords", 115 turns, no save corrupted.
  • Lampros73Lampros73 Registered Users Posts: 158
    vonKukis said:

    @Lampros73, I did play 2 campaigns last week:
    First one totally clear, no mods whatsoever, 120 turns, no save corrupted.
    Second one, all mods turned on (but not "Execute Lords", 115 turns, no save corrupted.

    Thanks. I am hearing the same story on the other forum: Execute Lords was responsible for the crashes, and they stopped once it was deleted.
  • vonKukisvonKukis Registered Users Posts: 6
    Lampros73 said:

    Thanks. I am hearing the same story on the other forum: Execute Lords was responsible for the crashes, and they stopped once it was deleted.

    Yeah, that's bad, cause I really miss this mod sometimes
  • BillyRuffianBillyRuffian Moderator UKRegistered Users, Moderators, Knights Posts: 39,119
    vonKukis said:


    Lampros73 said:

    Thanks. I am hearing the same story on the other forum: Execute Lords was responsible for the crashes, and they stopped once it was deleted.

    Yeah, that's bad, cause I really miss this mod sometimes
    Is there any chance the mod creator can fix it?

    "He uses statistics as a drunken man uses lamp-posts - for support rather than illumination." (Andrew Lang)

    |Takeda| Yokota Takatoshi

    Forum Terms and Conditions: - https://forums.totalwar.com/discussion/172193/forum-terms-and-conditions#latest

    "We wunt be druv". iot6pc7dn8qs.png
  • akakevinakakevin Registered Users Posts: 3
    This may have been fixed already as the following was addressed in the Execute Lords mod on 1/9/20:

    "sm0kin [author] Jan 9 @ 5:41pm
    Seems like the save corruption is somehow connected to the fact that the tmb king agent subtype is the only lord type of the subculture group. I disabled the execution feature for tomb kings lords entirely for the time being. I'll reenable it once I figure out why this happens."

    No other updates have been made since the 9th and I have not used this mod once it was determined this might have been the culprit of corrupt saves. I have not had a corrupted game since... of course, I also haven't used the mod since the update so it may be fine now. YMMV. Good luck.
  • Njk00Njk00 Registered Users Posts: 8
    edited January 2020
    Ok I have done a lot of testing and I can confirm that the culprit was the mod called Execute Lord.

    I have done almost 70 turns with zero mods with the very same faction that was crashing and I had zero issue.

    Based on my findings, CA has nothing to do with the corruption saves bug and everything was caused by the mod Execute Lord. They have now fixed the mod and after that I was able to play the old corrupted saved games without issues: I have even finished the Malus campaign!

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file