Welcome

Please register for Total War Access to use the forums. If you're an existing user, your forum details will be merged with Total War Access if you register with the same email or username. For more information please read our FAQ’s here.

Categories

Game does not run at all (first time run)

NTwisterNTwister Registered Users Posts: 1
edited January 23 in Performance & Graphics
Dear all.
To keep it short, after i download from Steam and click play, nothing happens at all. (fresh+first run)
I will describe in details what I have tried.

I download version 1.4 (at first), but after i click on play (on Steam), the button switched to "Stop" (meaning game running), then a few seconds later, it changed back to "Play" (meaning somehow, game stop).
And i see nothing happen on my screen, no error pops up, no detections on Antivirus (no files removed).
In task manager, i notice the amount of processes increased by 1, but i dont see any Three_kingdoms.exe (or anything similar).

Then, i decide to google and try other ways.....

Add exception to antivirus, check deleted or quarantine files (it turns out, my AV does not do anything to the game)
Click play and wait 30minutes... (for first time run, it's said that it would take longer time... so i tried to wait)
Delete game from steamapp folder, re-download, switch from version 1.4 to 1.3
Logout of steam, exit, relogin Steam,
I also try steam offline mode.
Verify integrity, move installed folder.
Turn off Steam overlay.
Restart computer.

Some discussion mentioned about "app data" and "The Creative Assembly" folder... but i did not find any CA folders in my appdata. Therefore, i can't provide any preference file or minidump.
(i'm using win7 x64 by the way).

My steamapp drive has almost 100gb of free space, so after download+install, i still have about 60gb left... more than enough for "game requirement".

Then, i saw some mentions about "window updates" and "re-install windows" would fix the issue.
So i tried to finish all possible updates on Windows 7.
But after 3 hours and finish update Windows, game still can't run.
I went through all the game .exe logs in Event Viewer and they are similar.
"event ID 1001", "event name PCA2"... (as attached below).

I also use no Mod.

At this point, i have no idea what's happening and why the game does not run.
(i'm playing other games from steam as well, and all are working just fine)

Can anyone shine some light into this matter?
Thanks




Comments

  • CA_MihaiCA_Mihai Registered Users, Moderators, CA Staff Mods, CA Staff, SEGA Posts: 4
    Hi NTwister,

    Sorry to hear that you are having issues when trying to launch the game.

    From what I read in your post, it seems that you might be missing one or more redists. Please go to the redist folder in *Steam location*\steamapps\common\Steamworks Shared\_CommonRedist\ and install the following:
    - from DirectX\Jun2010 run DXSETUP.exe and follow the instructions on screen
    - from vcredist\2013 run vcredist_x64.exe & vcredist_x86.exe and follow the instructions on screen
    - from vcredist\2015 run vcredist_x64.exe & vcredist_x86.exe and follow the instructions on screen

    Please bear in mind that you might have some of the vcredists already installed, so if you get a screen asking you to Repair, Remove, or Reinstall then cancel the setup and move to the next one.

    Hope this helps,
    Mihai. :)
Sign In or Register to comment.