Welcome

Please register for Total War Access to use the forums. If you're an existing user, your forum details will be merged with Total War Access if you register with the same email or username. For more information please read our FAQ’s here.

Categories

Modded Attributes Being Applied to More Units Than Intended

TheGrandWizardTheGrandWizard Registered Users Posts: 11
I created a new attribute group called "wh2_carnosaur" as I am giving the carnosaur its own group that gives it strider and the ability to hides in forests along with its normal fear, terror and rampage, and I put them in the group in the land_unit_tables table and it works fine but it also applies the attributes from this new group to some war machines and chariots like the War Wagons Gyrocopters and the Ithlimar Chariot and few others.

Comments

  • SuperMeloneSuperMelone Registered Users Posts: 14
    Does the key you used for your group already exists in vanilla?
  • TheGrandWizardTheGrandWizard Registered Users Posts: 11
    edited February 12
    I used wh2_carnosaur which shouldn't exist and I even tried just carnosaur which definitely doesn't exist.
    I dug a little deeper on this and I found out that the units effected by this new attribute group other than the carnosaurs that I assigned to it are all units that aren't assigned a group to begin with, this includes War Wagons (only the mortar and ror version), doom flayers, the 2 gyrocopters, and a few melee chariots. They just have a blank space for their attribute group in the Land units table. I tried making a group that just causes fear and assigned those units to that group which worked but only as long as the carnosaur group was deleted from the attribute group junctions table which obviously doesn't help me
  • SuperMeloneSuperMelone Registered Users Posts: 14
    Hmm this is really strange, I made some attribute groups myself a few weeks ago and i will check if I have simular problems
  • TheGrandWizardTheGrandWizard Registered Users Posts: 11
    Okay I figured it out, I just didn't put the group name in the unit_attributes_groups_tables

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file