Please register for Total War Access to use the forums. If you're an existing user, your forum details will be merged with Total War Access if you register with the same email or username. For more information please read our FAQ’s here.


Known IssueBroken Greenskin Confederation/Not gaining Legendary Lord Traits on defeat

dadboydadboy Registered Users Posts: 1
edited June 2020 in Campaign & Battle Bugs
*Note* Not sure if this is affecting anything, but I do have these mods enabled: Better Camera Mod, Recruit Defeated Legendary Lords, Legendary Lord Respec, Balanced Skill Points, Leaders of Legend (Lord/Faction Trait Overhaul); I am also opting into the v1.9.2 beta

I've been experiencing an inconsistency in my Mortal Empire Campaigns where when I defeat a Legendary Lord I do not gain their trait. It has happened twice now. The first time I noticed it, I attacked Queek as Khalida at Granite Massif where he was garrisoned. Then when I attacked him several turns later after he had come back I was able to get the trait. The second time I was playing as 'Ardboy's, and I attacked Azhag with Wurzag at Beschafen, not only did I not receive a trait I also did not get the option to confederate. I tried again, this time letting him attack me over the end turn as I lay siege to the city, same result. Then I retreated from the city sat in raiding camp stance, he attacked over the end turn, I defeated him and still nothing. It seems the issue is inconsistent, because in other campaigns things have worked properly even with the mods and in the beta. My Grimgor campaign was started after opting into the beta and with the mods on and I was able to get traits and confederate fine before. Has anyone else experienced anything like this?

Post edited by CA_Luna on


  • B0wmoreB0wmore Registered Users Posts: 2
    I have also been experiencing the same bug. I am playing a Azhag campaign in a head to head, and I don't receive LL defeat traits, and don't confederate other greenskin factions by defeating there faction leader. What's weird is the person I am playing against is not experiencing the bug and is getting traits and confederations. I am also using the v1.9.2 beta.

    Also to note I do have some mods enabled, but have not experienced this in other campaigns on the beta using the same mods.
  • endurstonehelm#6102endurstonehelm#6102 Registered Users Posts: 4,283
    its related to whether you choose Autoresolve or not. If you choose Autoresolve, you get the trait and confederation option. if you do a manual battle, you don't get either.
  • Boneyboy101Boneyboy101 Registered Users Posts: 3
    Playing as Arkhan on Vortex campaign and have same problem, defeated Settra then Tiktaq-to shortly after and gained no traits. Like hell am I gonna auto resolve those two battles cos we all know Arkhan would be coming out of that even more dead than he already is! CA please fix!!!

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file