Welcome

Please register for Total War Access to use the forums. If you're an existing user, your forum details will be merged with Total War Access if you register with the same email or username. For more information please read our FAQ’s here.

Categories

CTD on Splash Screen

DefinitelyNotADealerDefinitelyNotADealer Registered Users Posts: 1
edited July 26 in Crashes
After 545 hours of playtime I'm getting a CTD on the 'Warhammer 2' splash screen.
Here is what I have tried so far;
- Disabling all mods
- Reinstalling
- Running as Admin
- Repairing Steam Library Folder
- Moving game file from SSD to HDD
- Firewall settings
- Deleting 'Warhammer 2' folder from 'AppData'
- Updating graphics drivers
- launching with dx11
- restarting PC after all the above

I have all the DLC

PC Specs;
AMD Ryzen 5 3600
MSI B450 Gaming Pro Carbon AC
RTX 2070 Super
32GB RAM @3200hz
Windows 10 x64

I'm at a total loss right now, any help would be super appreciated.
Post edited by DefinitelyNotADealer on

Comments

  • ralhralh Registered Users Posts: 1
    I just experienced the same thing - 559 hours in, I played the game a bit today, shut it down without any issues. Tried relaunching an hour later, crash on splash screen every single time.

    No mods.

    As far as I can tell nothing major happened in the PC in that one hour that I wasn't playing.

    Also, I tried most of the same things you did, without any effect.
  • SebastelianSebastelian Registered Users Posts: 21
    Same here... Played today and now a few hours later this... Not the first time this happend out of nowhere. Nothing new installed, no new drivers no nothing but suddenly this buggy mess won't launch again. Reinstall and deleting folder is all of no use. CA fix your garbage please...

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file