Welcome

Please register for Total War Access to use the forums. If you're an existing user, your forum details will be merged with Total War Access if you register with the same email or username. For more information please read our FAQ’s here.

Categories

SolvedGame Freezes on Startup

llamasxllamasx Registered Users Posts: 5
edited August 2020 in Crashes
As the title says I am experiencing freezing on startup. I can see the opening screen with the logos but my cursor spins and the program stops responding.

I have tried verifying files and running as an administrator.

I do not have a Preferences.script file.

DXDIAG goes like halfway but can not finish. IDK why.

My game does not crash but it perma freezes.

i5-8600k
RX VEGA 64 6GB
16 GB DDR4
Windows 10

I am on Japanese system locale. Idk if that changes anything.
Post edited by dge1 on

Comments

  • ca_ivanovca_ivanov Registered Users, CA Staff Posts: 8
    Hey @llamasx

    Have you by any chance installed the game in a non-latin character folder? (eg. Cyrillic or Chinese/Japanese characters)
    If so, can you please try installing the game in a folder with latin characters and see if that resolves the issue?

    Also can you check if your graphic drivers are up to date?
    And can you check if the game made any mini dump files here: AppData\Roaming\The Creative Assembly\Troy\crash_report

    Cheers!
    FORMAL DISCLAIMER: Any views or opinions expressed here are those of the poster and do not necessarily represent the views or opinions of The Creative Assembly or SEGA.
  • llamasxllamasx Registered Users Posts: 5
    ca_ivanov said:

    Hey @llamasx

    Have you by any chance installed the game in a non-latin character folder? (eg. Cyrillic or Chinese/Japanese characters)
    If so, can you please try installing the game in a folder with latin characters and see if that resolves the issue?

    Also can you check if your graphic drivers are up to date?
    And can you check if the game made any mini dump files here: AppData\Roaming\The Creative Assembly\Troy\crash_report

    Cheers!

    I shouldn't have a problem with any of those. Also, I don't have the crash report file. This is probably because the game has not actually crashed but rather perma freezes on startup. I don't see any Japanese or weird ASCII characters in any of the files. I'm quite confused as this problem is isolated to this game specifically.
  • llamasxllamasx Registered Users Posts: 5
    You know what I think it is the system locale. I will change back to U.S. and update you.
  • llamasxllamasx Registered Users Posts: 5
    In pic 3 you can see that the file location replaced \\\ back slashes with ¥¥¥
  • llamasxllamasx Registered Users Posts: 5
    llamasx said:

    You know what I think it is the system locale. I will change back to U.S. and update you.

    Can confirm that changing system locale to U.S. fixed the problem. Thanks for the help.
Sign In or Register to comment.