Please register for Total War Access to use the forums. If you're an existing user, your forum details will be merged with Total War Access if you register with the same email or username. For more information please read our FAQ’s here.


Units not moveable since x rounds

PeyttanjoPeyttanjo Registered Users Posts: 2
Since the moment i took over the city Megara, I can't move neither the troop with Agamemnon, nor the agent priest Korinsia.

As you can see in the screenshots, I haven't moved them and it seems as if they would be stucked together.

Before the fight, the agent was part of the troop with Agamemnon and i splited her off to use her ability on the city.
Then i started the fight with Agamemnon + troop as well as another hero + troop -> took over the city -> moved to the next round -> moved the other hero + troop -> tried to fuse the agent priest Korinsia back into Agamemnon's troop (didn't work) ->
tried to move Agamemnon's troop (didn't work) .... and here we are


Sign In or Register to comment.