Please register for Total War Access to use the forums. If you're an existing user, your forum details will be merged with Total War Access if you register with the same email or username. For more information please read our FAQ’s here.


User Info RequiredCampaign Event BUG

DevelXDDevelXD Registered Users Posts: 7
edited December 2020 in Campaign & Battle Bugs
Greeting Dear CA,

I would like to report that the event bug, basically a bug on the events being unable to pop out causing all characters To be unable to move and unable to end turn + unable to save. This issue had been happening very frequently since this lastest patch.
May I know if there are any solutions to it? It happened to all 3 of my wood elves campaign

Mortal empires - turn 23
Mortal empires - turn 41
Vortex campaign - turn 37

May I know if there are any solutions for this? Clearing history and setting advice frequency to High won't work
Post edited by CHARLOTTEB_CA on


  • HallvardgnHallvardgn Registered Users Posts: 1
    edited December 2020
    I get the same bug when trying to play as Throt.
    Tried starting a campaign 6 times and I get the bug between turn 3-5 without fail.

    Edit. Found a work-around that works for me. Press ctrl+s to quicksave, then load that.

    Edit2. OK, it allows me to continue playing. But the missions for Creature-Killer and Whip of Domination doesn't appear. I'm guessing they are what bugs out. So Won't be able to get those items.
    Post edited by Hallvardgn on
  • StarlightEagleStarlightEagle Registered Users Posts: 1
    The bug is happening to me and my friend every time and faction, dwarfs, dark elfs, wood elfs etc. this made the game just unplayable, we tried everything, quick save dont work, there is also no event in the diary.
  • ReaverOfReaverOf Registered Users Posts: 2
    I just had the same bug during Vortex Sisters of Twilight Campaign. The ritual for Oreon's Camp finished and I had a dire warning from the narrator and the game is stuck just like if I had to press OK on an event but nothing to press.

    Reloading doesn't work and it happens everytime the ritual is finished.
  • CHARLOTTEB_CACHARLOTTEB_CA Administrator Registered Users, Moderators, CA Staff Mods, CA Staff Posts: 3,400
    Hey Guys!

    Would I be able to grab some save files to assist me in looking into this for you? =)
    Formal disclaimer: any views or opinions expressed here are those of the poster and do not necessarily represent the views or opinions of The Creative Assembly or SEGA.
  • epic_159735248823BYf8ZEdepic_159735248823BYf8ZEd Registered Users Posts: 2
    Did they fix it?
  • alenalen Registered Users Posts: 1
    If you are using the No confederation penalties mod from Flying Fox that's what causes the problem
  • tranhanam0027tranhanam0027 Registered Users Posts: 1
    Can confirm that the No confederation penalties mod is what is causing problems for me as well.
    Disabling it solved the bug.
  • AeronL7AeronL7 Registered Users Posts: 2
    Every time I get the Amber Bow quest unlocked at level 8, the end turn button becomes greyed out and I'm unable to move, save , end turn or anything. The events tab always has an orange exclamation mark on it but I can't bring it up to view the events.
    This will consistently freeze my campaign every time I play Marcus.

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file