Welcome

Please register for Total War Access to use the forums. If you're an existing user, your forum details will be merged with Total War Access if you register with the same email or username. For more information please read our FAQ’s here.

Categories

The Last Roman custom battle issues

JPocockJPocock Registered Users Posts: 3
Hi,
I tried contacting Sega about this problem after being directed to them by Steam and in the email they in turn directed me here. I bought The Last Roman DLC but after several reinstalls of the whole game and just the individual DLC I am still experiencing problems. When on the custom battle menu, only the Ostrogothic Kingdom and Roman Expedition are available and they are mixed in with the Grand Campaign factions whether I select the Grand Campaign or the Last Roman from the drop-down menu above the map. As well as this, when I uninstalled the Last Roman the entire game would crash instantly when I click on the custom battle option. I have no mods, just the main game (Tyrants & Kings Edition) initially installed from a disc and I bought through Steam the Blood & Burning DLC. Everything that came with the initial game and the blood effects have all worked fine. I am a bit embarrassed to admit that I am not very tech savvy so if anyone is able to help me please explain things as simply as possible, sorry!

I apologise if there is already a discussion opened on this very subject but I wasn't sure how to find it without trawling through every single page. I also apologise if this isn't the right subheading to put this under but I thought it was the right one from the descriptions.

Any help would be very much appreciated because I was really looking forward to The Last Roman and I was so disappointed to discover this issue.

Many thanks,
Jack

Comments

Sign In or Register to comment.