Please register for Total War Access to use the forums. If you're an existing user, your forum details will be merged with Total War Access if you register with the same email or username. For more information please read our FAQ’s here.


1.7.0 broke my game despite BETA 1.6.1 properly set before hand.

XakyrieEleisonXakyrieEleison Registered Users Posts: 3
So playing my campaign for a week. Was about to head into emperor declarations.

1.7.0 rolls around, I see the news. I'm like "Okay, will it break my save? Oh they even tell me specifically to set the Beta! I'm Safe!"

Midnight, still no Beta option for 1.6.1 so I wait for next day.

Today. Launch Steam, see the update download prepared for later.

Immediately set Beta to 1.6.1.

Download canceled, never downloaded.

Launched game, all good, loading screen gets to full, you can almost smell the map getting loaded...

Crash, exit to desktop.

Launched again, noticed the LAUNCHER says "1.7.0" version despite my Beta setting.


Verified File Integrity.

Post edited by XakyrieEleison on


  • XakyrieEleisonXakyrieEleison Registered Users Posts: 3
    edited March 2021
    the autosave and most recent hard save is ruined, but the 2nd last hard save worked. most odd.

    The only notable thing in those is that I recently annexed a vassal with only the basic -20 trust modifier.

    It cost me a dozen turns but it's fine, as long as I didn't lose everything.
  • MaxMaraveMaxMarave Registered Users Posts: 9

    same thing is happening to me. Crashed and impossible to install the beta 1.6.1.

    None of my saves works.

    I'm about to loose hours of progression.

    please help

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file