Welcome

Please register for Total War Access to use the forums. If you're an existing user, your forum details will be merged with Total War Access if you register with the same email or username. For more information please read our FAQ’s here.

Categories

In ProgressTroy Total War: Trees and Grass Glitching

canderson274canderson274 Registered Users Posts: 5
edited September 7 in Performance and Graphics
Hi,

I have recently been having an issue with the trees and grass.

1) All trees are showing up as a deep black in battle maps, except if the camera is very far away, then it turns into green.

2) As I move the camera around in the battle map the grass textures load in and out as squares, so there is a lot of grass squares texture popping in and out, which is very distracting.

Is there a known fix for these issues? Loving the game otherwise. I am playing on ultra graphics settings and have attached my dxdiag.

I have verified the game files, and also reinstalled the game but that has not fixed the issues.

Thanks!
Post edited by CA_Dimitar on

Comments

  • canderson274canderson274 Registered Users Posts: 5
  • canderson274canderson274 Registered Users Posts: 5
  • canderson274canderson274 Registered Users Posts: 5
    Found something interesting - I previously had Anti-Aliasing off, the issue above happened. However, when I switched to 4x anti-aliasing the trees were green and fixed! I tested out different anti-aliasing and the following occurred:

    Off: Trees Black, Grass Flickering
    FXAA: Trees Black, Grass Flickering
    2x: Trees Green, Grass Black and Flickering
    4x: Trees Green and Grass Green, Grass Flickering
    8x: Crash to Desktop

    Very interesting results here - currently I will play at 4x anti-aliasing but I get a lot better framerates when off, so I'm dropping my resolution from 1440p to 1080p.

    I've heard from a few other users that they see the same issue as well.
  • TheodoreanTheodorean Registered Users Posts: 1
    This issue still persists, even after updating to the latest game version, as well as latest AMD drivers.

    Same card as OP, Radeon RX 5700 XT
  • canderson274canderson274 Registered Users Posts: 5
    Just wanted to update - the issue of the black textures are still an issue, as Theodorean mentioned I believe it is a card issue? RX 5700 XT.

    The grass flickering has gone away now so that is good. However these black textures don't allow me to get higher frames since I have to put 4x AA on.
  • MacIsGrMacIsGr Registered Users Posts: 2
    My PC with the RX5700 has exactly the same problem with the game and 4x AA solves it but shouldn't happen at all. Any info on an upcoming fix?
  • McGarnagleMcGarnagle Registered Users Posts: 8
    Just writing to confirm that this issue still persists. I also have a Radeon RX 5700 XT card. The bug occurs with anti aliasing set to Off or FXAA, but disappears when set to MSAA settings. Having to play with MSAA on reduces my frame rate too much so have refunded on Steam until the issue is fixed.
  • CA_DimitarCA_Dimitar Registered Users, Moderators, CA Staff Posts: 157
    Hello all,

    Thanks for the detailed reports. We were able to reproduce the issue and it has been sent to the dev team for further investigation.

    Cheers,
    Dimitar
    CA Sofia QA Team

    FORMAL DISCLAIMER: Any views or opinions expressed here are those of the poster and do not necessarily represent the views or opinions of The Creative Assembly or SEGA.
Sign In or Register to comment.