Please register for Total War Access to use the forums. If you're an existing user, your forum details will be merged with Total War Access if you register with the same email or username. For more information please read our FAQ’s here.


In ProgressStuttering/Lag spikes across Campaign and Battles

ProfKhaineProfKhaine Registered Users Posts: 6
edited May 2021 in Performance & Graphics
Sorry if this sounds like a broken record but I've been finding a lot of incomplete guides and uncertain fixes from 2019 to now, so figured I'd try and get some solid confirmation as to what the status is here.

Build: v1.7.0 Build 16713.2221481

Detailed description: Long story short, serious lag spikes that strike both on the campaign map and in individual battles. Typically occurs when moving the camera in the campaign map, but similarly moving the camera in battle tends to produce the same effects. Lasts for a few seconds, usually less than five, before returning to normal for a period, then another spike.

Reproduction Steps:
- Playing Sun Jian, Romance, Rise of the Warlords
- Uh... play the game, as far as I know
- Game is unmodded

Details of any solutions that have already been attempted:
- Run in Windowed
- Set priority to High via task manager
- Set processor affinity to 1-7 rather than 0-7 via task manager
- Lower graphics settings
- Ensure drivers are up to date
- Ensure not running DirectX 12
- Prayer?

Attached should be DxDiag, preference script, and modified.log
Post edited by CA_Luna on


  • BillyRuffian#6250BillyRuffian#6250 Registered Users, Moderators, Knights Posts: 40,999
    Have you got that Radeon Chill thing running. If so, try turning it off.

    "He uses statistics as a drunken man uses lamp-posts - for support rather than illumination." (Andrew Lang)

    |Takeda| Yokota Takatoshi

    Forum Terms and Conditions: - https://forums.totalwar.com/discussion/172193/forum-terms-and-conditions#latest

    "We wunt be druv". iot6pc7dn8qs.png
  • ProfKhaineProfKhaine Registered Users Posts: 6
    Chill is currently disabled, but thanks for the tip!
  • CA_LunaCA_Luna Registered Users, Moderators, CA Staff Mods, CA Staff Posts: 3,613
    Hey ProfKhaine!

    I'd advise verifying your steam files! It looks like you have a pack file missing according to your mod.log! and see if that helps! =)
    Formal disclaimer: any views or opinions expressed here are those of the poster and do not necessarily represent the views or opinions of The Creative Assembly or SEGA.
  • Rewan#2358Rewan#2358 Registered Users Posts: 4,918
    Isn't that pack missing only because he doesn't own the Fates Divided DLC ?

    My personal collection of hazardous tests and quickfixes (yes this is a link).
    Wondering why you get some traits on your characters this may give you a vague idea

    Balance enthusiast, I like tinkering and messing with stuff and values. Cool heads prevails !
  • ProfKhaineProfKhaine Registered Users Posts: 6
    Update, have now verified files and seemingly all files verified successfully, none re-downloaded.
  • FLSFLS Registered Users Posts: 4
    Maybe not related to the same issue, but still about stuttering on the campaign map.
    On the different starting dates I experience stuttering while going over the nanman territory where the towns are discovered. I do think it is linked to the different name tags of each city, which are different from the han ones. I think it is caused by the name tags as when the region is not discovered there is no stuttering.
    There has been stuttering issues since patch 1.6, but the regions in which it happened have varied making it difficult to put the finger on what was causing it.
    I do not have the nanman dlc. I have all other dlcs. No mods used. I did try with mods which only made the stuttering worse.

    Can this be fixed?
  • ProfKhaineProfKhaine Registered Users Posts: 6
    edited May 2021
    I suspect it's a different issue considering I've seen these lag spikes in the north as well (and on battle maps), but maybe it's related in some way? Not sure. At this point I'll believe almost anything :)

    As a clarification to how rough it is, I'll drop from consistently above 30-45 FPS to about 4-10 FPS abruptly. It's... not unplayable, otherwise I wouldn't have 10+ hours already, but is rather frustrating to try to play a long campaign with. Really want to love this game but it's making it hard lol.
  • ProfKhaineProfKhaine Registered Users Posts: 6
    edited May 2021
    Update, 1.7.1 is out and... no change. Well, a boy can dream...

    Latest efforts to provide aid considered maybe the laptop itself is the issue, rather than 3K. Well... they ain't worked either. These including using Armoury Crate to set performance to Turbo (!), with the hopes that added fan work would help if temperature was the issue. No such luck. Tried a fix for laptop stuttering as detailed in link below, no change. Drat.

    Tentatively hoping that with no more content updates, more time for bug fixes & diagnoses? Maybe? :) Staying positive...

  • FLSFLS Registered Users Posts: 4
    After advancing in my campaign, the lag and stutter has appeared in other regions.
    The issue is most certainly linked to the symbols and name tags that disappear if you press on "K" (in other words the UI) as there is no lag nor stutter when in cinematic mode. But the regions with stutter vary from faction to faction (same campaign with different factions) so I really have no clue what is exactly causing it.

    ProfKhaine, do you have the furious wilde dlc?
    As these issues started with the release of that dlc and I personally don't have it, I was thinking of the possibility that the furious wilde dlc has in what you download something (for the UI) that the base game is missing that results in stutter without the content of the dlc. This idea seems wierd to me, but well we never know. I really want to be able to play and enjoy the game. Been almost a year that this issue has existed!
  • ProfKhaineProfKhaine Registered Users Posts: 6
    I do not have the Furious Wilds DLC either. It would be very strange if it turns out that's the issue yeah, but it's not out of the question considering that dependency. Very bizarre.

    In my case it also applies to multiplayer, though that's not unexpected. Still managed to get through a yellow turbans campaign with a buddy though :) .

    I haven't tried the K button approach, will do that and see if it changes things (not that it'd be very playable without UI but y'know... just for more information!)
Sign In or Register to comment.