Please register for Total War Access to use the forums. If you're an existing user, your forum details will be merged with Total War Access if you register with the same email or username. For more information please read our FAQ’s here.


Can't get Total War launcher to work for Total War Three Kingdoms. Help would be greatly appreciated

cmarinos51cmarinos51 Registered Users Posts: 4
So, essentially what's happening is whenever I boot up Total War 3K the launcher will load briefly before just freezing on a blank screen with a pop up that comes up every 30 seconds asking if I want to wait for the launcher to respond or just start the game immediately. The game is still playable, however, if I wanted to use mods (which I do) then this issue prevents me from doing so. In case it was a mod issue I actually deleted all the mod folders in \steamapps\workshop\content\779340 before unsubbing to all of them in the steam workshop. I also tried uninstalling and reinstalling the game, that hasn't worked. I tried verifying local files, that hasn't worked. Tried going to the betas to find the launcher_release_candidate which this game doesn't even have. I've pretty much tried all the common suggestions I've found in forums and searches on multiple sites and nothing has worked. I can only imagine at this point it's something completely different or uncommon so I'm at the end of my tether. Any suggestions, and I do mean ANY suggestions would be appreciated at this point.


Sign In or Register to comment.