Please register for Total War Access to use the forums. If you're an existing user, your forum details will be merged with Total War Access if you register with the same email or username. For more information please read our FAQ’s here.


New multiplayer session stuck due to "Waiting for players..." issue

BakymirBakymir Registered Users Posts: 1
Hello everyone,

Version: 1.12.1
Build: 19592.2397581

Detailed description:
Upon launching an online co-op multiplayer session, the game gets stuck on "Waiting for players...".
This issue occurs if both players are connected to home network via a router.

We managed to get the multiplayer game working by connecting my friend (client) via a 4G network.
Though, our game didn't last long as we experienced another issue later on (probably needs a new thread).

Both of us, players, have the game installed on the SSD. Both have good internet connection.
We never experienced any issues with other multiplayer games from our Steam library, including Total War: Warhammer.

Reproduction Steps:
Create an online multiplayer game and launch it. The game gets stuck immediately after the map is loaded.

Details of any solutions that have already been attempted:
  1. Checked if the game is allowed in Windows Defender Firewall.
  2. Tried port-forwarding Steam recommended ports on both routers (not sure if worked).
  3. Tried disabling the antivirus software.
Cannot be generated, as the issue occurs right after the game is loaded.

Weird behavior
During our initial test I (host) picked the Chevaliers de Lyonesse, and my friend (client) picked the Order of Loremasters.
Once the game is loaded, I am queued up first in the order and we experience the aforementioned issue.

If I (host) pick a faction that starts second, then the game loads normally without the "Waiting for players..." issue.

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file