Please register for Total War Access to use the forums. If you're an existing user, your forum details will be merged with Total War Access if you register with the same email or username. For more information please read our FAQ’s here.


User Info Required[Nurgle Domain] Plagefather domain bugged after battle on quest point

PierzardPierzard Registered Users Posts: 19
edited February 2022 in Campaign & Battle Bugs
Hello here are the steps to reproduce how the issue happened for me:

- Attacked Miao Ying's army while she was on the quest point : "Path to Argus the plague moon"
-> After the battle, the point was automatically triggered because my army now stood on it, and my army was healed (plus attrition bonus reduction activated).
-> The quest marker (green) that was on the point disappeared.
-------> However, the Demon Prince battle did not activate in front of the garden.
No way to trigger the quest battle anymore, going in front of the garden entrance did nothing either.

See picture bellow, quest is considered done:

Note: can share the saves before and after bug if needed
Post edited by CA_Dimitar#6718 on


  • WrathbabyWrathbaby Registered Users Posts: 1
    I've had the same issue

    -Attacked Katarina's army on the point (except my quest marker was on The Great Tree)
    -Point triggered, army healed, attrition reduction activated
    -Quest marker disappeared (checked in the objectives panel to make sure it definitely completed)
    -No daemon prince battle appeared (no pop up, no blue circle at the mansion, idk what is actually supposed to appear)
    -Ran right up to the mansion, tried standing right on it in all the stances available
    -Kairos and Harald (Chaos Undivided) were a ways behind me so I waited to see if they could claim the soul - Harald
    arrived at the mansion and got the soul. Sadge.

    Hopefully this doesn't turn out to be a recurring issue. Will be v v salty if I play through 50 more turns and come back to find the same thing happens again.
  • jcmesserschmidtjcmesserschmidt Registered Users Posts: 8
    Same issue as well. Fought a battle on the tree of life marker, got the buff + replenishment, then no further marker appeared to progress the quest.

    I ran to the house but there was nothing to interact with. Skarbrand ran up and won the event.
  • epic_159737451767PVXK6yfepic_159737451767PVXK6yf Junior Member Registered Users Posts: 21
    Same issue here. Greasus was on the objective, I attacked and wiped him, quest progressed and I got the buff + replenishment but now have no marker to finish the realm. I also visited the last two points of interest and moved to the front of the mansion hoping something would trigger it but... it's dead jim.
  • CA_Dimitar#6718CA_Dimitar#6718 Registered Users, Moderators, CA Staff Posts: 1,002
    Hey all,

    Thanks for your reports and all the information. Could you provide us with your save files from the time you experienced the issue?

    CA Sofia QA Team

    FORMAL DISCLAIMER: Any views or opinions expressed here are those of the poster and do not necessarily represent the views or opinions of The Creative Assembly or SEGA
  • PierzardPierzard Registered Users Posts: 19
    edited February 2022

    Sure here are two saves from release 1.0.0

    The save "TEST BUG" is from just before the fight that causes the bug.
    The save "BUGGED PLAGUEDADDY" is 3 turns later when I realized it was bugged.

  • PierzardPierzard Registered Users Posts: 19
    Quick note though, I don't know if anything was fixed with patrch 1.0.1, or if auto resolve has a part in it, but by auto resolving the battle (can win the fight by seducing one of Miao Ying's jade warriors in the save "TEST BUG"), the quest is correctly triggered.

    The "BUGGED PLAGUEDADDY" is still bugged though for sure.
  • jcmesserschmidtjcmesserschmidt Registered Users Posts: 8
    Here's mine. Note that the "Seek Immunity" quest is complete, but there is no followup quest nor marker at the mansion.
  • DeathypooDeathypoo Registered Users Posts: 1
    I just ran into this problem myself. Has there been a fix or workaround yet?
  • jcmesserschmidtjcmesserschmidt Registered Users Posts: 8
    Deathypoo said:

    I just ran into this problem myself. Has there been a fix or workaround yet?

    I don't think so. Temporary workaround is don't fight on quest markers. Looks like it's a known issue according to the 1.1 patch notes so hopefully fixed in 1.2

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file