Please register for Total War Access to use the forums. If you're an existing user, your forum details will be merged with Total War Access if you register with the same email or username. For more information please read our FAQ’s here.


In ProgressMissing option to enter Forge of Souls as Boris

steam_1630793943266yAfwIRsteam_1630793943266yAfwIR Junior MemberRegistered Users Posts: 138
edited February 2022 in Campaign & Battle Bugs
Completed the four realms of chaos and received the final quest but I'm missing the option to enter the forge of souls when entering a rift.

The only thing of note was that the Poxwalkers completed all the realms before me however I stopped them at the forge of souls. I was in the realm of Tzeentch at the time and had completed Nurgle and Khorne realm before that.

Restarted the game.
Tried entering with two different armies.
Load an older save.
Move the army through rift travel and tried different rifts through out the world.
Enter Slannesh realm and leave by accepting the first tempting gift.
Closed the rift and waited for a new one to spawn.

Below are SC and uploaded save game file.

I have all 4 souls as Boris

I have the final quest

The quest timer is still counting even though I cant do anything

No option to enter forge

Post edited by [Deleted User] on


Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file