Please register for Total War Access to use the forums. If you're an existing user, your forum details will be merged with Total War Access if you register with the same email or username. For more information please read our FAQ’s here.


In ProgressEnd Turn Crash

epic_159740133831BR32o4mepic_159740133831BR32o4m Registered Users Posts: 2
edited March 2022 in Crashes
Build: v1.0.0. 12381.2524378

Detailed description: Playing Daemons of Chaos at the end of turn 59, once all the AI factions have ended their turns, the game freezes and then crashes to desktop. Things that stand out:

- Ursun's roar was a few turns ago, portals should spawn soon.
- A Rogue Army destroys an army I hired at the end of this turn.
- Dedicated myself to Chaos Undivided.

However, I've had portals spawn before without issue, and the same rogue army destroyed another army I hired from a different ally the turn before. I've attached all the required files, including different dumps for the crash. Hope it all helps!

Reproduction Steps:
- Totally unable to reproduce this. Had a Tzeentch campaign that never had this issue.

Details of any solutions that have already been attempted:
I have seen some people suggest to keep the hired army alive in order to evade the crash, though I'm afraid that in this instance it might be impossible.
Post edited by CA_Dimitar#6718 on


  • AkarniTheBlackAkarniTheBlack Registered Users Posts: 2
    Hey I had the exact same issue and it was because of a hired army being destroyed. I had to reload to a point where I could send the army to safety. Hope that helps.
  • steam_164531871216BTGk0cnsteam_164531871216BTGk0cn Registered Users Posts: 5
    Had the same issue, hired army gets destroyed causing a crash. I should also note that the army was no longer in my service and I was at war. Game is fine until that army dies. I can reproduce the crash everytime if I go personally kill the ex-hired army. I am starting to think that the hired army gets some sort of unique attribute that is causing a bug when it dies. I have to restart now because I dont have a save anymore prior to when I hired the army.
  • epic_159740133831BR32o4mepic_159740133831BR32o4m Registered Users Posts: 2
    Unfortunately that's 10 turns and a lot of hours ago, so if the problem is indeed the hired army then I'd rather just wait for a fix :sweat_smile:
  • RipRendRipRend Registered Users Posts: 2
    edited February 2022
    I have this issues as well finally worked out that its the Ally army i hired 30+ turns ago. As soon as it dies the end turn crashes. I tried to hire it but it is stuck in mustering mode so i cannot run it away quickly enough to save it

    I think that by breaking my alliance with the allied army faction it fixes the issue... It did not but I lost visibility of it and it somehow survived. 22 turns later it came back into sight, died and game crashed.
    Post edited by RipRend on
  • jimmy7heduckjimmy7heduck Registered Users Posts: 1
    I can confirm I've had this issue too apparently caused by the destruction of a borrowed allied army. Moving them out the way on another save fixed it. Hope this bug is looked in to!
  • steam_164508352796JyzGonesteam_164508352796JyzGone Registered Users Posts: 2
    Having the same issue as-well. Can't get the ex-hired army to safety. Hope we can get a hotfix for this quick.
  • ringil86ringil86 Registered Users Posts: 2
    I am having the same issue but it is crashing on the turn of a Slanneshi sub faction clear on the other side of the world from me so it can't be related to any army I've ever hired. My guess a hired army from another faction is causing the issue. I was about 4 turns away from completing the campaign and now I am stuck and very frustrated.
  • folmer04folmer04 Registered Users Posts: 2
    I am experiencing the same issue in my Legion of Chaos campaign where the game crashes upon the end the turn when an allied army I previously hired are wiped out.
  • TramontanaTramontana Registered Users Posts: 1
    Same issue with legion of chaos, its becuse hired army dies.
  • romainbromainb Registered Users Posts: 2
    Same issue as Legion, but without any hired allies army.
    As I have read it really seems to be related to Legion for this specific crash.
  • Cadbury_NuzlockeCadbury_Nuzlocke Registered Users Posts: 5
    edited March 2022
    Wanted to add onto this that I've encountered the same issue as Legion. Have verified and all that jazz. I'm on turn 150+ and I'm one turn away from getting the last demon soul, lol. I feel like a sap for having played at all honestly--should've waited a couple patches I guess

    edit: I wanted to update this to say I was able to confirm my issue was 100% caused by an ex-army (hired via alliance and then returned to its original faction) getting destroyed. I went back enough turns to prevent this from happening, which was honestly a pretty infuriating process of herding cats on the world map, and I had to sacrifice a handful of armies and cities to make sure everything fell into place. This may not be the sole reason for the Legion crashes but it's clearly a bug in the game itself--hopefully they'll fix it in the next patch for the game.
    Post edited by Cadbury_Nuzlocke on
  • FlabboTVFlabboTV Registered Users Posts: 1
    edited March 2022
    Same issue for me too, daemons of chaos and crashing in the same manner at turn 121. I've hired a single army and confirmed they were safe but it crashes regardless.

    Worst part is its sucked the enthusiasm out of me, I've started a new campaign but just don't have the same interest as before, I really want to finish what I started.
  • MenorMenor Registered Users Posts: 1
    edited March 2022
    Legion undivided same issue here. Ex-hired army 30 turns later dies and game crashes on turn end.

    Edit: I hired the ex-army again and tried to kill it off while it is hired and game crashed again on end turn

    Edit2: I tried to kill it off while it was my turn by suicide the army into enemy settlement and it still crashed after the end turn. Doesn't matter if it is your turn or the end turn when it dies it just crashes. Very annoying.
    Post edited by Menor on
  • SerpentrasDSerpentrasD Junior Member Registered Users Posts: 8
    Same stuff, had a loner army once but was abandoned a view turns prior to that.
    Only difference is here that I am the Demons of chaos and on turn 139.
    My rig informaton:Intel MMX 166mhz,32mb RAM, ATI 4mb VRAM, 2GB SEAGATE, Roland Soundblaster 16, 15" CRT, Windows 95

    Actual gaming rig looks similar, only better
  • FriendlyHeavyFriendlyHeavy Registered Users Posts: 11
    Exact same issue here.
    Playing Legion of Chaos, during end turn after all the AI factions have gone the game hangs and crashes to desktop.
  • FennykunFennykun Registered Users Posts: 1
    300+ turns in. Legions of Chaos owns almost the whole map and the borrowed army was destroyed a turn ago. Going for the domination victory and really don't want to restart. It looks like the same issue but I can't be sure because I destroyed the whole allied faction.
  • OrenathOrenath Registered Users Posts: 1
    I think I have the same issue. Hired army died during end turn step, after all factions finish their turns the game hangs for thirty seconds or so, then crashes to desktop.
  • TomwhiteauTomwhiteau Registered Users Posts: 3
    Confirming the same. Playing as the Demon Prince, about turn 80. Back 40-50 turns ago I borrowed an army. Hit end turn and the AI loses that army in battle during their turn, and then I get a crash to desktop when the last AI faction turn ends and mine is supposed to start. Absolutely no way to save this campaign short of loading like 20 turns ago and babysitting that army forever.
  • reno29reno29 Registered Users Posts: 1
    Same here, legion chaos ( demon prince), turn 100 or 120, start crashing at the end of the turn, try normal fixes and still crashing, previously in turn 40 I borrowed and army .
  • Splitz#2375Splitz#2375 Registered Users Posts: 7
    Same issue around the 100 turn time, multiple times. Demon Prince, hired army (and fired) and kept happening because the army is wandering in enemy territory and gets whacked. After I set back my starts multiple times from 90's into early 100's and this ends up being nearly unavoidable. Stopped playing, and this needs a fix.
  • TIME070TIME070 Registered Users Posts: 1
    Please provide a fix. This army now dies because of nurgle plague :) Nothing I can do against it. Gonna play a different campaign without buying an allied army I guess
  • Calvin86Calvin86 Registered Users Posts: 5
    Can confirm this exact issue. After borrowed army was killed it crashed after end the last ai faction did their turn. Reloaded a few turns back, didn't borrow the army and have had no problems after. Seems consistent. A bit worried since I borrowed another army a while back and worried it could happen anytime if that army bites it
  • CA_Dimitar#6718CA_Dimitar#6718 Registered Users, Moderators, CA Staff Posts: 1,001
    Hey all

    Thanks for all the reports and the provided giles. Your issue has already been sent to the dev team

  • Legion_of_Chaos_ManLegion_of_Chaos_Man Registered Users Posts: 1
    what a huge bummer. Same issue on turn 140. I didn't do a deep dive but there are 2-3 ally armies that I'd returned that are in conflict zones.
  • Goby#1382Goby#1382 Registered Users Posts: 10
    edited March 2022

    Here is another campaign stuck at this crash. Again Daemons of Chaos. I also have borrowed an army in this campaign.

    I no longer buy games weeks or even a few months after launch and this is the reason why. I should've held my excitement. Gamers should not be expected to test your games for you.
    Post edited by Goby#1382 on
  • Goby#1382Goby#1382 Registered Users Posts: 10
    edited March 2022
    I can confirm the borrowed army in my campaign got destroyed before the start of my turn. See the Graeling army led by Ulf Alderbrand get wiped after trying to take on a rift.
  • FagerlundFagerlund Registered Users Posts: 1
    Same issue here. Borrowed army dies, game crashes at end turn. Saving the army post-pones the crash - until it dies and the crash comes back.
  • ReevaReeva Registered Users Posts: 6
    So I wasn't aware of this issue until it happened to me, my legendary campaign is literally unplayable now, there's no way of undoing or preventing that army I hired from being destroyed... god lord
  • Goby#1382Goby#1382 Registered Users Posts: 10
    I don't ever write reviews on Steam, but I had to warn others this time. This issue is clearly not that rare - its easily reproducible, it has happened while playing different factions and always when a borrowed army gets wiped. This issue should have easily popped up in pre-launch QA testing.
  • IamNotArobot#8850IamNotArobot#8850 Registered Users Posts: 5,758
    same, first time but yes, also i had an army request
    *Justice, cats and CONFEDERATION ENABLED for the Tomb Kings and Vampire Coast! feat mummies and Apophas.
    *Exclusive DLCs for Tomb Kings, Vampire Coast, BM, CW and WE! #DLCsAreRacesToo
    *Remaster all WH1 and WH2 faction icons for WH3!
    *Ogre Kingdoms core race or death!
    *Bring back settlement conquering artworks!
    *Gnoblar Carpet for Greesus
    *Improve UI

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file