Please register for Total War Access to use the forums. If you're an existing user, your forum details will be merged with Total War Access if you register with the same email or username. For more information please read our FAQ’s here.


Unable to go to Forge of Souls



  • BalubeluBalubelu Registered Users Posts: 1
    Have same problem with Kislev campaign

    Got all 4 souls but dont have the option to teleport to the Forge of Souls anymore.

  • AntoniovealAntonioveal Junior Member Baetica/HispaniaRegistered Users Posts: 6
    Hello there,

    I've been playing my Ku'gath campaign since the game was released. I had the quest to intercept Skarbrand, I tried joining the forge of souls but I couldn't go there to stop him.

    For some reason Skarbrand didn't finish the campaign so I did my stuff, got Nurgle soul and I had the quest as completed, then I did the same with Tzeentch but my quest doesn't appear as completed, also I can't join the Forge of Souls because of this.

    I'd love if this could be changed as I've spent a lot of time on this campaign. Thanks in advance.

  • roodjohroodjoh Registered Users Posts: 1
    Hello, I've also had the same issue on Kislev.

    My file is attached, thank you for any help - really want to finish my campaign!
  • Realistic#7120Realistic#7120 Registered Users Posts: 2
    Hey guys just want to know if you have an update on this. CA posted yesterday on steam community about current issues and I think it's appalling that this major problem to gameplay isn't included as something urgent. I've never seen such a blatant disregard to "paying" players as this.

    I do understand that launching games is an immense amount of hard work throughout and after it comes out and forgive me for saying this:
    This is a BIG issue. Imagine paying for a game and it being broken right when you are "finishing" it.

    Let me sum it up: The Climax of the MAIN campaign that is the FIRST end-game experience that players get to HAVE is NOT WORKING.

    Thanks for reading.
  • viktorj560viktorj560 Registered Users Posts: 2
    Same thing, kislev campaign as Katarin.
    Nurgle got 4 before me, didn't show up when intercepted in forge of Souls.
    After that got 4th soul, Katarin cannot go into forge of Souls no more.
    Game breaking af.
    I know there is a war and everything going on in the world, but this must be addressed as game breaking asap, cause even top Warhammer total war streamers as legendoftotalwar stopped Livestreams on wh3 until u Fix the chaos campaign game breaking bugs, even if it takes 6 years to fix them.
    So please treat this as high highest priority please.
  • Jay__RoboJay__Robo Registered Users Posts: 1
    Well it's annoying that this thread is so old and the issue isn't fixed by the Dev team. I've just encountered the bug myself was looking forward to unlocking belakor. Game breaking bug.
  • CunningSTuntCunningSTunt Registered Users Posts: 1
    same for me... when will this be fixed?!
  • upgrayedddupgrayeddd Registered Users Posts: 1
    same issue, really disapointing, kills the fun completly, do you guys at least have some awnsers for us I mean it seems to be a common problem and ruins the game completly
  • XksiXksi Registered Users Posts: 1
    Hi! Same problem here! Someone got the four souls before me, so I went to the forge to intercept him. After that, I returned to Nurgle Realm to get the last soul, wich I did.

    Something that I think nobody said but maybe it is important. After every soul is gathered a Belakor video pops up and the army is transported to the normal map, but when I got the soul no video showed up and the army remained on Nurgle Realm. When I went to the closest rift there was no option for the Forge, and no portals active on the map, so I stayed there for a few turns until the next portal event. Maybe that was the issue. When it popped a few turns after I tried again. Could go to the map, but still no Forge option. So travelled to the map to see if I had to go from there, but nope.

    I played the battles manually btw

  • viktorj560viktorj560 Registered Users Posts: 2
    Ok, CA continues to bury their heads in sand and pretend they aren't aware of this game breaking bugs and problems.
    Well, let them pretend they don't know why is everyone boycotting their games, blood dlc and everything else in the future, just as the bad reviews(mixed already), just as YouTuber as legend are doing it, then.
    But ignoring all of us and making fools out of us, they had it coming.
    I mean, we would have been happy with a simple "we are aware of it, we are trying to fix, don't know when" acknowledgement, but not even that happened.
    So serves them Right.
  • GianniBrizziGianniBrizzi Registered Users Posts: 2
    I have the exact same issue playing with chaos legion... collected 4 souls but the forge of souls won't appear in the rift 's menu. So frustrating after almost 400 turns...
  • NocNaturalNocNatural Registered Users Posts: 1
    I guess i post my save file here as well.
    Playing as Ogre Kingdoms - Greasus on Legendary/Hard , messed up in the beggining so Katarin got the first 4 souls , i was able to intercept her then i got to work to collect my 4th soul (the Khorn one) and when i got it , got the quest and video to go and kill Belakor well id like to but the game wont let me , incredibly frustrating.

  • VøidzzzVøidzzz Registered Users Posts: 3
    Cathay got his 4 soul while rift was open and now there are no rift for anyone, i cant even fight cathay to stop them. I was looking optimistic all the time ignoring all negative comments but im done. This game is not done yet and tons of game breaking bug happening. Howcome you published buggy game like this? Not gonna send any of my save files becouse i already messed up trying to save my campaing. So sad.
  • Daikoku#4767Daikoku#4767 Registered Users Posts: 3
    edited March 2022
    Hi Everyone,

    I know we've been posting staff here but I got an observation.
    If one of the Team Members could check it and confirm would be nice.

    So I've been playing this campaing of Chaos Undivided and I decided not to go for the souls run and not to intercept them. While fighting Kislev I've allowed others get the 4 souls. And so the madness started. There are a lots of portals, yes, but not from every each of them deamons come out, but this time I had the option to go to the Forge of Souls.
    So I've moved my Deamon Prince there and camped my ass for the PC Players. Killed every Legendary Lord that approach me and went for my first soul. After that I had like, I don't know, 30 to 40 turns of not much rifts and no FoS rush. Now I'm at the second go, as the button finally reappeared and went camping.

    It seems that the cooldwon for FoS entry as a tiny bit off, not 15 turns but more like 30-40.
    Deamons are not bursting from the portals, they are rather random.
    And I can slowly dominate PC Players and gather my souls every time I kill Legendary Lords that enter the FoS.

    Should this be like that or is it a form of a cheesse/bug? Maybe this perspective could help both the players and the developers.

    **Oh, and I play on Very Hard Difficulty, both campaing and fights**

    Best wishes,
  • McSwagginsMcSwaggins Registered Users Posts: 1
    NodrykX said:

    Sorry if this a known issue, I checked the posts but didn't find it.
    After stoping Kugath in the forge of souls to win because he gathered the 4th souls before me. I succeded to gather my 4th souls but i'm no longer able to go to the forge anymore.

    I added my save if it can help. I would love to be able to finish this difficult but very fun campaign.
    As always keep up the good work ! Thanks in advance.

    I ran into the same issue on a slannesh campaign. Hard difficulty.

    Intercepted Kugath at the forge of souls.
    Got my last demon soul - Tzeench.
    Portals no longer show button to go to forge of souls.
    Victory conditions show that I have all four demon souls.
    It looks like the "Soul Interception" challenege is broken. Even though I defeated Kugath it has not gone away.

    Tried to completely kill kugath off the map but the bear died before I could destroy his faction completely.
  • Reubster101Reubster101 Registered Users Posts: 4
    I now also have the same issue with my kislev campaign. Have got my 4th soul but now seem unable to get to the soul forge, only can travel to the 4 realms, all of the realms show I have the solve as does the UI on the top. Not sure if any recent patches were supposed to fix this? I have had to jump back and forth to the soul forge to intercept. Didn't auto-resolve any soul battles but didn't get any cut scene when getting my forth soul so that may have signaled the start of the issue?
  • taddisontaddison Registered Users Posts: 3
    edited March 2022
    Same Problem here with a Kislev campaign. Just got my 4th soul and can't access the forge. Cathay got their 4th soul after me and there is no option to go to the forge and intercept. Most of the chaos factions got their 4 souls before me but I was able to intercept them.

  • deusstufforumdeusstufforum Registered Users Posts: 1
    edited March 2022
    I'm having the same problem with a Kislev campaign. Nurgle got their 4th soul before I did and I never got the intercept quest. This is my first campaign so I thought the quest would come up when enough time had passed and I kept going. After I got my 4th soul (Nurgle) I noticed that I didn't get credit in Victory Conditions for it or for my 3rd soul (Tzeentch). There's no intercept quest for me and no option to go to the Forge of Souls either to intercept or finish the campaign. The latest patch came after I got my first two souls but before I got my 3rd and 4th.

    Eventually, another AI faction (Daemon Prince) got a 4th soul and I still never got an intercept quest and still can't go to the Forge.
  • tharumtharum Registered Users Posts: 10
    edited April 2022
    Allo Allo

    I am now having the same issue as all the above. Kislev got 4 souls before I did. Intercepted them. Got the 4th Soul. Went to click on rift to go to the Forge of Souls. No option to go to the Forge of Souls.

    Are you able to assist? File is attached.

    Many thanks

    *Edit* I have intercepted an AI player before and done exactly the same (different faction) and this error did not come up.

    *2nd Edit* After reading more of the above it looks like the issue is the interception quest didn't complete despite having intercepted the AI's Army. There is no option to abandon this quest.
    Post edited by tharum on
  • ChakLongChakLong Junior Member Registered Users Posts: 2
    Just adding to the list of players facing this issue, no save file since it'll likely provide only duplicate info. Playing as Ogre Kingdoms on Very Hard difficulty, the rifts do not show an option to go to the Forge of Souls, and the same Soul Interception quest that others have noted is also stuck in my mission log. I have all four souls, which the UI shows me in three different places.
  • Reubster101Reubster101 Registered Users Posts: 4
    Patch hasn't fixed the issue for me. Anyone else?
  • SaxBee13SaxBee13 Registered Users Posts: 1
    Any update on this @CA_Dimitar

    Just got all 4 with the ogres and I'm having the same problem. What a waste of so many hours ]=

  • nika631nika631 Registered Users Posts: 1
    Same issue here with Ursus Boris on Very Hard. An update would be nice.
  • K-vmanK-vman Registered Users Posts: 1
    Hi, I have a similar problem. why'll playing as Northern Cathay I have all 4 souls and the interception mission for Nurgle but I still don't have the option to go to the Forge of Souls

    running on PC, Build ID- 8469482, Game version- 1.1.0
    this is my first time posting a save so hopefully i do it right
  • VepsyoghurtVepsyoghurt Registered Users Posts: 1
    I've also experienced this issue with Ursus Boris on VH/VH where I am unable to intercept an enemy army at the forge of souls. Any updates on the fix for this bug?
  • SergaresSergares Registered Users Posts: 1
    Something similar happened to me, I can't intercept anybody at the forge of souls, I have 3 souls but some factions already have 4, because I let myself get bribed from slanesh, so I have to go intercept them but I can't.
    I can close the gate, and use it to travel to other gates and the game let's me click the option to travel to the forge of souls but nothing happens so I can only wait and loose.
  • Burntheday202Burntheday202 Registered Users Posts: 1
    having the same issue- 1.2 doesnt seem to fix it.

    Skarbrand- at a rift- have 4 souls- cant intercept OR take the rift to finish my campaign. simply dont have the option at the rift screen.

    Please Help!
  • steam_163804654173ShZXUvisteam_163804654173ShZXUvi Registered Users Posts: 1
    Hello @CA_Dimitar !
    Do you have any update on this? It is still an issue after 1.2 and so many people need a solution.
  • grimkudla#8233grimkudla#8233 Registered Users Posts: 4
    same issue for me :neutral: was able to go FoS before 1.1 , but after this patch I cant go there at all >>>dont see option + I got stuck with quest stop Nurge lord etc...

    when it wiil be fixed - it was suppose to be done in patch 1.2 (???) , but looks like bothing has changed
  • steelwork#9181steelwork#9181 Registered Users Posts: 90
    same issue for me.4 souls, can't go to the forge. can't unlock belakor.

This discussion has been closed.