Welcome

Please register for Total War Access to use the forums. If you're an existing user, your forum details will be merged with Total War Access if you register with the same email or username. For more information please read our FAQ’s here.

Categories

Total War: Warhammer 3 bug report

Stormrage124Stormrage124 Registered Users Posts: 4
1- Graphical bug after clicking on Skullcannons, sometimes permanent (giant white-ish cross in the middle, encompasses 40% of the screen).
2- Units sometimes stop attacking enemies even when told to attack. Toggling off guard mode doesn't solve the issue either.
3- Game crashed once while viewing the spectacular realm of slaanesh in chaos wastes.
4- Music stops completely sometimes in-battle.
5- Goblin Scrapelaunchers (Ogre Kingdoms unit) have a big problem with repositioning. They bug out when given an order and stuck in the opposite direction. Ironblasters sometimes have this issue as well, but not as much as Goblin Scrapelaunchers.
Post edited by CA_Luna on

Comments

  • Stormrage124Stormrage124 Registered Users Posts: 4

    as for 5, a screenshot wouldn't show the problem. but I could explain it. I give the scrapelauncher and order, to move forward or backward. When they arrive to the destination, they unnecessarily circle around, then they reposition on the the opposite direction (backward, if I ordered them to face forward. and if not backward, they stay sideways instead). After they circle around, I try to fix their position, but they keep circling around again, and by then they are useless. The only way is to let them the way they were from the beginning of the battle. Sometimes, repositioning works, sometimes it doesn't. I'm not sure if this was intended or not, but I shared a screenshot and the save file.
  • RenzovS#6358RenzovS#6358 Junior Member Registered Users Posts: 6
    In the battle of the blood soul, my artillery entered in a melee fight causing it to lose its artillery pieces. After replenishing its units, and re-docking the artillery, the unit thought it was still in melee mode, but with the artillery pieces in hand. After clicking to attack the enemy, my game crashed.
  • kyokamarukyokamaru Registered Users Posts: 10
    I would like to Report Graphical bugs introduced in Patch 1.1

    -Antialiasing systems totaly bugged everything is pixelated especially when the camera is moving the grass antialiasing got horrendous, the units and buildings/ terrain items like rocks and trees look pixelated and disgusting

    -TAA and TAA High antialiasing iff enabled produce flickering light across edges mid range on everthing : units trees grass buildings etc...

    -SSAO since patch 1.1 is not functioning properly and makes a glowing effect around units and grass and trees iff they are in shadows looks absolutley horrible.

    Visual effects like flame bits from explosions, fire ball, or other spell VFX look Absolutley low rez pixelated cr*p iff viewed from further back, looks horrible.

    In general the game since 1.1 looks godawful vibrating lights and vibrating pixels everywhere on grass on units Especially noticable when anything is is motion, static objects look bad but not as bad as objects in motion where all the pixelated edges just vibrate.

    Pls roll back the graphical chages i stopped playing the game now looks so bad up close with all the visual bugs its absolutley disgusting.

    Tested these visual bugs on 4 different PC-s same results on almost any graphical settings the main Problems seem to be Total lack or bugged Antialiasing system on FXAA, TAA, TAA High, and SSAO system bugging out and producing ugly glowing effects on objects in shade.
  • alexander.hinterberger@live.at[email protected] Registered Users Posts: 1
    edited June 8
    A bug since last patch:

    Loading a campaign game leads to crash to desktop (Always). This does not happen with all safefiles. I think its only the safefiles that have been saved since the last patch. I think it came last friday (3.June.2022)
  • steam_164513810568W0zlPDtsteam_164513810568W0zlPDt Registered Users Posts: 1
    Playing as Katarin, using quick deals, it shows the Deal Chance to obtain a Defensive Alliance with Stirland as +0.2. When I click the Initiate Diplomacy button to get the Defensive Alliance, the Deal Chance shown in the bottom right is now -12.8 (Baseline -25, Relative Faction Strength +11.7, Diplomatic Prospects +1.2, Distance -0.7). Even after exiting diplomacy entirely then reloading, the error persists.
  • toughmerktoughmerk Registered Users Posts: 1
    As Cult of sigmar, Cannot recruit empire knights even when blacksmith or higher is built in home province. Havent tried in other provinces as of yet but no matter what character or abilities empire knights show "Cannot recruit, building is missing: blacksmith" even though it is built.
  • Stormrage124Stormrage124 Registered Users Posts: 4
    There is a bug regarding "Belakor's Shadow" mechanic of turning mortals to daemon princes in the turn time wait.
    if the marked mortal loses a second battle against Belakor, the turn time increases by 10. The marked lord had only 3 turns left to turn, but after he lost the second battle, turn time appeared to be 13. However, after 3 turns, he became a daemon prince anyways. So it's a visual bug.
  • Stormrage124Stormrage124 Registered Users Posts: 4
    Defeat traits do not show the name of the Legendary Lord defeat under the description.
  • gebabjegebabje Registered Users Posts: 1
    edited August 29


    Repanse de Lyonesses "Sword of Lyonesse"-mission battle is unwinnable(immortal empires). Even after the enemy is completely wiped out and all objectives completed the battle won't finish until the timer runs out resulting in valiant defeat. Might have something to do with AI allies since few dwarf units keep patrolling endlessly across the map(potentially looking for enemies but i'm honestly not sure why). Also noticed that the patrolling unit's can stop moving if one or more of the models get stuck on terrain but this is unlikely related to the main issue of the battle not ending since having tried several times now I can confirm that the battle won't end even if there are no units stuck on trees or roots. I also tried to position all my units in a way that they cover most if not all the forest areas in hopes of reducing the need for the AI to check fog of war areas but this doesn't help either.

    In attached picture you can see the situation about 10-15 minutes after the enemies have been wiped out and there are 2 dwarf units still patrolling and I'm covering most of the area.

    Edit: problem seems to be 4th enemy army not spawning. Seems to be one of the armies that should be at the battlefield from the start looking at the videos of how this battle should had gone. Looking from your spawn point it's the rightmost army that is not there. Game seems to think the army is there but it isn't.
    Post edited by gebabje on
  • epic_159733303005vqD4p2Zepic_159733303005vqD4p2Z Junior Member Registered Users Posts: 6
    Cant zoom in on campaign map.

    So whats happining is that the campaign cam changes the limit on how much I can zoom in on the campaign map. It get worse the longer the campaign. By turn 80 or so the game is unplayable for me.
  • TheorakTheorak Registered Users Posts: 1
    Ulthuan Map incompatible with ambush.

    The battlefield streched into the decorative mountains, the units spawned on top, the enemy did not spawn at all. The battle could only be conceded, not finished.




    Matchup: MP Immortal Empires, High Elf Ally vs AI Dark Elves
    Trigger: coastal region ambush
  • vie_dragonvie_dragon Registered Users Posts: 177

    2- Units sometimes stop attacking enemies even when told to attack. Toggling off guard mode doesn't solve the issue either.

    This is still in the game.
  • steam_165806807669JXfWiBssteam_165806807669JXfWiBs Registered Users Posts: 1
    Minor but annoying bug. While playing as the Dark Elves (Lokhir) and selecting one of the Black Arks, when I hovered over one the building tiles (with available build options) the build tree opened downwards, extending off the bottom of the screen, instead of upwards. I could still continue by opening the full building tree and selecting build options there, but I had to restart the game to fix the issue. It has happened twice on two separate sessions.

  • GnoffGnoff Registered Users Posts: 1
    I hope this is the place for bug reports.
    1: in skaven Clan pesitlens, the plauge will not appear or spread. It just kills your spreader and nothing happens.
    2: in Repanse the lLyonesse quest battle for her sword, the battle won't end. even if you killed every enemy.
    I hope this helps in the bug fixing :)
  • ClopclopclopClopclopclop Registered Users Posts: 1
    MP COOP Immortal empire.

    When you get threatened by AI and refuses. It asks your ally if he wanna join then games crashes down
  • arasvolodka1#8391arasvolodka1#8391 Registered Users Posts: 1
    I encountered a REALLY bad bug, in playing as the dwarves karaz-a-karak on turn 113 the warhost of the apocalypse declares war on Kislev, I get a "your ally has been attacked" notification, but if I click "enter war on side of ally" the game freezes. I've reloaded over and over again. I was almost ready to give up on the campaign because I couldn't get past that turn but realized I could just declare war on that faction to avoid the crash. That fixed the problem but that should be a priority fix.
  • #331930#331930 Registered Users Posts: 1
    In a defensive battle of Black Hole(? Czarna Dziura PL) is bug when the enemy units cannot pass through any of entrence to town. Except Chaos Warhounds.


  • Smile#6637Smile#6637 Registered Users Posts: 1

    Immortal Empires campaign. Playing as Slanesh (but probably not faction related bug). Latin numbers on the buildings constructed review side menu are one unit higher than they suppose to be. Building names, etc. are correct. Screenshot attached. Thanks! Hope it helps to improve the game I like!
  • Chipolatta#2370Chipolatta#2370 Registered Users Posts: 1
    Immortal Empires Campaign, playing as Legion of Chaos dedicated to Nurgle, I have 2 issues :
    • French translation tells that the Nurgle Heralds lords will be recruited with +20 levels for Gift VIII (the others are all tooltipped to +10)
    • Despite reaching the Gift VIII, my new Nurgle lords are still level 1.


  • Berth0ld#1742Berth0ld#1742 Registered Users Posts: 1
    Immortal Empires Campaign, playing as Nurgle I got attrition from vampiric corruption even though the corruption was below 50 and my own Nurgle corruption was above 50
  • #133572#133572 Registered Users Posts: 1
    Clyostra Direfin starting enemy army stuck in the Black Forest settlement and can't attack even with enough movement. https://steamcommunity.com/profiles/76561198871869666/screenshots
  • #90767#90767 Registered Users Posts: 1
    There is a current bug in immortal empires where heinrich kemmlers chaos tomb blade passive isn't working as intended

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file