Welcome

Please register for Total War Access to use the forums. If you're an existing user, your forum details will be merged with Total War Access if you register with the same email or username. For more information please read our FAQ’s here.

Categories

Known IssueForge of souls teleport not showing up

BuurinatorBuurinator Registered Users Posts: 4
edited March 2022 in Campaign & Battle Bugs
Greetings!
Playing as Khorne, I'm at turn 160 and entered the forge of souls to intercept Kislev who got the 4th daemon soul. Once entered the forge with Skarbrand, im standing on the small rocky platform with nowhere to go. The small teleport which is supposed to take me further into the forge, simply doesn't show up... I had hoped that it got fixed through the recent patch, but unfortunately that wasn't the case.
Any help would be much appreciated, since I don't really feel like spending another 80 hours and eventually risk running into the same problem. I tried reloading and going back to an earlier save game to play from there, multiple times. However none of the things I tried seemed to work...
This problem seems very strange, so I really hope you guys will be able to fix it
I've linked the save game file for you.

Thanks!

Yours Sincerely,
Mads


Post edited by [Deleted User] on
Tagged:

Comments

  • BuurinatorBuurinator Registered Users Posts: 4
    Hey Charlie
    Lovely! Thank you for the efficiency!

    Looking forward to hearing from you and crossing my fingers that you'll find a solution :)

    Thanks,
    Buurinator
  • BuurinatorBuurinator Registered Users Posts: 4
    Hi Charlie

    Its been quite a while since ive heard anything from you. I certainly hope you´ve spend the time trying to fix this issue?
    My game is still glitching and I wont be playing it until you´ve come with solution.

    So please, fix this issue, cause it´s ruining my experience and desire to play total war.

    Buurinator
  • dormandudormandu Registered Users Posts: 3
    One thing I can add to this conversation, having the same problem, is that I noticed I did not have all souls in my quest menu even though I had 4 checkmarks at the top of my screen. In the end, my problem was I didn't have any option to go to the forge from the rifts.

    I also noticed that no AI went to the forge, even though they had all their souls.
  • BuurinatorBuurinator Registered Users Posts: 4
    Dormandu did you find asolution to this problem? :)

    It really sucks major balls to encounter this problem, cause you're just locked- no matter what you do.. and developers don't do **** about it.

    Please let me know if you find a solution

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file