Welcome

Please register for Total War Access to use the forums. If you're an existing user, your forum details will be merged with Total War Access if you register with the same email or username. For more information please read our FAQ’s here.

Categories

[Bug Report] Medieval II DE on Steam - Missing voices

ZensalinZensalin Registered Users Posts: 3
Hello,

SEGA Support and Feral Interactive Support directed me here.

(I allready went through the basics with SEGA Support: Veryfing game files twice and checking if the DLC are enabled in steam.)

The issue is: The non-english localizations of Total War: Medieval II - Definitive Edition on Steam ships the Kingdoms Expansions with missing voices.

The easiest way to reproduce is to change language to german (Or any other non-english) and start a Teutonic Campaign as the Teutonic Order. When clicking models on the world map like generals, captains, priests, etc. they won't play a voice line.

This happens across the board for most factions in all four expansions but only in the non-english versions.

Presumably this is caused by packaging and distributing the wrong files, as these issues are not present in the english steam version or any of the non-english retail/boxed versions.

The voices.idx and voices.dat files for the expansions may be the fault, they are only 1KB in the translated Steam version, but are a lot larger in the various translated boxed/retail versions.

This issue was reported back in 2014 as well and was said by a CA employee to be looked at, yet there never was a follow up.
Thread from 2014: https://forums.totalwar.com/discussion/comment/1230975

Instead of necroing the old thread, I'm creating this new one.

Anyone from CA: Please provide and update on the situation.

Best regards

Comments

  • FritzvomWaldFritzvomWald Junior Member Registered Users Posts: 135
    edited April 1
    It's a relatively easy fix, check here: [Resource] Quickfix für stumme Fraktionen

    As that is a German language guide here the essence of it for mute factions of other local languages that have mute factions (Spanish, French etc):
    I recommend to install my sound devkit and then edit the descr_sounds_accents.txt file in there (use Notepad) by moving mute factions from their accent slots to slots that work in their language. To get to that directory simply right click it's desktop short (not the log one) and choose 'open file location'.
    After that simply start the mod with it's short cut and test. If it works then simply copy the data\sounds\events.idx and .dat file to your main game's data\sounds directory. I suggest to make back up of the original files before copying.
    Post edited by FritzvomWald on
    author.png
  • ZensalinZensalin Registered Users Posts: 3
    Thanks for the links, but that is a (quite complicated and time consuming) workaround, as would be me simply copying the files from a correct physical copy, but neither of that absolves SEGA and CA from fixing a bug that has been known and recognized as one 8 years ago.
  • FritzvomWaldFritzvomWald Junior Member Registered Users Posts: 135
    edited April 1
    As I said in the other thread - CA hasn't done anything in the last 10 years other then merging the executable files and calling it later definitive edition.

    Which means this is as easy as you will get it, although I could describe how to do it from scratch if you want it really complicated and time consuming.

    My guess: between download and installing my small mod (the installer is automatic, simply click through), editing the text file, running the mod once and copying those two files it shouldn't take you longer then 10 minutes.

    No easy fix here I am afraid - unless you upload those two events files later for others.
    author.png
  • nelvanteinnelvantein Registered Users Posts: 5
    edited April 9
    Thanks for this workaround buddy.

    Can I make it so for example, Denmark generals give a long speech that is esentially a copy from Spain or a faction that has a long speech? Because Denmark, Hungary, Poland, the Moors, etc generals simply say an one liner and start the battle, tested in main campaign from your devkit mod.

    I have the steam definitive edition, I play in spanish language.
  • FritzvomWaldFritzvomWald Junior Member Registered Users Posts: 135
    edited April 9
    The full battle speeches based on traits of the leading general and\or his opponent are defined in export_descr_sounds_prebattle and are only available for a select few 'accents':

    English, French, German, Mediterrean

    A number of other accents use 'one liners' - if an accent is not listed in the above file then it's factions will not even have those one liners unless the factions are defined in the descr_sounds_db file.

    Which means you will have to allocate your faction to an accent that has those long speeches or copy that section from one of those cultures into one that hasn't got it. But the latter may have hilarious consequences - like having a moorish general holding long speeches with a strong British accent.

    You should have no problem trying this out with my devkit. Once you are happy with the result you can then update the 'events' files in the game's main directory.

    Note: you need to remove affected factions from the descr_sound_db file once you have copied those sections for them (their accent).
    author.png
  • nelvanteinnelvantein Registered Users Posts: 5
    Thanks for the response, I can't seem to manage it though.

    I edited the descr_sound_accents and the export_descr_sounds_prebattle, then I get the one liners from the other factions, but not the full speech.

    Then I edit the descr_sounds_db with notepad (it's xml) but then I get no speech at all. Any idea of what else i can do?
  • FritzvomWaldFritzvomWald Junior Member Registered Users Posts: 135
    edited April 10
    I am guessing something happened at either the accents file or the pre battle one.

    1. accents - by moving a faction into an accent that already has long speeches you should get those speeches. Note that this does not work in regular custom battles as there are no traits with any army leader, eg it will always be one liners there.

    2. pre battle - underneath the start of the accent's section:
             accent English
                      element VNV_OPENING
    You should now copy all lines from the elemnt line, up to before the element ENEMY_ID line underneath the accent line of an accent hat is missing that section, eg East_European. I would also suggest to remove the one liner section there completely, they may actually over ride the VNV entries:
                      element ONE_LINER
                                        event
                                                 folder data/sounds/Voice/Human/Localized/Pre_Battle_Speech
                                                      East_European_One_Liner_1.mp3
                                                              ..../...
                                                      East_European_One_Liner_49.mp3
                                        end
    After that run the devkit all the way until campaign start and try again with an character that you woudl expect to have the required traits (see the list of traits in pre battle).
    author.png
  • nelvanteinnelvantein Registered Users Posts: 5
    Thanks for the help man, no results though, I don't think It's possible. I still just get either one liners or nothing.
  • FritzvomWaldFritzvomWald Junior Member Registered Users Posts: 135
    edited April 10
    Let me run a test if I can get Russia to do long speeches. They are EE culture and otherwise have only one liners.

    And here you are:

    To test directly with the dev kit I copied the 'world' directory from my bare geomod mod into the devkit's directory (data\world) as it has all the factions unlocked. If the factions in your main game are unlocked then use that world directory, else download and install Bare Geomod from here: https://www.twcenter.net/forums/showthread.php?352216

    1. removed russia from descr_sounds_db - make sure not to leave an empty line
    2. copied the element vnv_opening section from accent English to accent East_European
    3. removed the element Oneliner section from accent East_European
    4. Saved and tested with Russia by attacking Smolensk with Duke Vlodyod (I changed his co-ordinates in descr_strat to 212, 163 to save me two turns reaching Smolensk)
    5. Nice speech about pox ridden knaves where before there was a simple 'get at them' - make sure to give it a second or two to focus on the general and to start the speech.

    All that's left now is to copy the events files (IDX\DAT) from the devkit to the main game
    Post edited by FritzvomWald on
    author.png
  • nelvanteinnelvantein Registered Users Posts: 5
    edited April 10
    I did the entire thing reinstalling the devkit just in case and uh only mediterranean speech seems transferable, for some reason the other ones don't work. The main factions don't even have voices, only mediterranean ones.

    I verified game files just in case and It seems spanish Medieval 2 only has those in the end :| .

    Edit: I think I may just switch and play in English language, thanks for your tips, they still work.
    Post edited by nelvantein on
  • FritzvomWaldFritzvomWald Junior Member Registered Users Posts: 135
    edited April 11
    In general every non english version has several accents missing, you will need to establish which ones work and which have full battle speeches.

    Switching to English in Steam, doing all the changes, and then switching back to Spanish should work but I am not 100% sure if your changes will get reversed (never tried in practice). I would suggest to make a copy of the data\sounds directory (after the English changes, before switching back to Spanish) in case that happens. All it takes then is to simply copy back the content of the English back up - having English speech while having Spanish text otherwise.
    author.png
  • nelvanteinnelvantein Registered Users Posts: 5
    edited April 12
    The changes do get reversed, I then paste the old sound folder back and I get mediterranean factions in spanish, the rest are in english, all those factions speech start with "NEEDS TRANSLATION:". A bit weird, not too bad for me.
  • FritzvomWaldFritzvomWald Junior Member Registered Users Posts: 135
    edited April 13
    Thanks for coming back with that info, never tried it myself. 'needs translation' - is that the speech's subtitles?

    If so then it would get quite involving to resolve it, unfortunately that file is not present in my basic mod installation of 'Bare Geomod' and will thus require unpacking of all files as I am not sure I am permitted to upload original files. Much easier to simply disable sub titles.

    The file is ...\data\text\prebattle_speeches_subtitles.string.bin

    The 'simplest' method would be:
    1. install Bare Geomod - https://www.twcenter.net/forums/showthread.php?352216
    2. switch to English and unpack - https://www.twcenter.net/forums/showthread.php?550619
    3. copy the above file into Bare Geomod and switch back to Spanish
    4. sort out the sound issue as before
    5. use the desktop short cut of Bare Geomod to play the game

    Note: if you use the linked unpack method then the unpacked files will be in C:\Unpack - which means you can simply delete that directory once you have transferred the file, instead of having those thousands of files intermingled in your game's directory when using the default method.
    author.png
Sign In or Register to comment.