Welcome

Please register for Total War Access to use the forums. If you're an existing user, your forum details will be merged with Total War Access if you register with the same email or username. For more information please read our FAQ’s here.

Categories

User Info Required"Corrupted by Nurgle" trait not going away after patch

MZS_8901MZS_8901 Registered Users Posts: 3
edited April 2022 in Campaign & Battle Bugs
I thought that the patch notes said the negative corruption traits would not go away if a character spent time away from that type of corruption. I am still having an issue with this.

I was playing as Slaanesh and both of my armies and all four embedded heroes got the trait "corrupted by Nurgle". I moved them to provinces that had 0 Nurgle corruption present and only had Slaanesh and Chaos United corruption, thirty turns later and every character still has the trait.

This completely halted my campaign. I could not continue conquering other territories because doing so then required my army to sit in a city for countless turns just to heal. I wound up having to find a save from before the characters got corrupted and hope for the best.
Post edited by CA_Dimitar#6718 on

Comments

  • CA_Dimitar#6718CA_Dimitar#6718 Registered Users, Moderators, CA Staff Posts: 1,002
    Hey @MZS_8901 ,

    Thanks for the report. Could you attach a save file with your issue present?

    Cheers,
    Dimitar
  • Ardashir#3077Ardashir#3077 Registered Users Posts: 6
    edited April 2022
    I have the same issue with a Khorne campaign, this is a new one after the patch.
    I attach my latest save, every army except for Skarbrand has at least two charecters with the trait.
    Post edited by Ardashir#3077 on
  • CA_Dimitar#6718CA_Dimitar#6718 Registered Users, Moderators, CA Staff Posts: 1,002
    Hey @Ardashir ,

    Thanks for the save file. Sorry about the inconvenience, but could you attach your save file to a post in the thread?

    Cheers,
    Dimitar
  • MZS_8901MZS_8901 Registered Users Posts: 3
    Unfortunately I no longer have the save file. Over the weekend I tried loading the campaign again and my armies suddenly no longer had the corruption after reloading the game. I continued playing after that point and the save file was overwritten. I also had this happen on a Khorne campaign though. I noticed that if I sent the affected army to an area with low nurgle corruption and periodically saved/loaded the trait would disappear once the game had loaded. If I just continue playing though the trait does not go away.

    I am sorry I cannot provide a save file to be more helpful. If it happens again I will post a save file.
  • MZS_8901MZS_8901 Registered Users Posts: 3
    I had it happen again but this time I have save files.

    The save file "Turn 1 out of nugle" was when I moved N'Kari to a province with no Nurgle corruption.

    The file "Turn 7" was seven turns after that. When I created the save N'Kari and both embedded heroes were still corrupted. Ending the turn still showed them as corrupted and hindering unit replenishment, but when I loaded the game again the corruption is suddenly gone. I don't know why loading the game again makes the corruption go away.

    I also included the save file from the turn before in case that helps. It is "Turn 6"

    I hope this helps. I'm glad I can at least load games to get rid of corruption, but it's a little tedious. I can at least continue to spread to good word of Slaanesh around the world now. Even if there might be the occasional issue, I'm still very much enjoying this game. Keep up the hard work CA.
  • Ardashir#3077Ardashir#3077 Registered Users Posts: 6

    Hey @Ardashir ,

    Thanks for the save file. Sorry about the inconvenience, but could you attach your save file to a post in the thread?

    Cheers,
    Dimitar

    Hi Dimitar, sorry for the delay but now i've just edited my post and attached the save file, thank you.
  • EmbraceDeath#2328EmbraceDeath#2328 Registered Users Posts: 50
    Also just had this issue. Love to have to have it fixed. @Ardashir was 7 the magic number to load the game? Any work around would help.

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file