Welcome

Please register for Total War Access to use the forums. If you're an existing user, your forum details will be merged with Total War Access if you register with the same email or username. For more information please read our FAQ’s here.

Categories

Completely unplayable since upgrading to i9 12900k

stehilton94stehilton94 Registered Users Posts: 1
Build: 1.7.1 Build 17233.2290568

Detailed description: No matter what I do the FPS won't go above 35, dropping as low as 5 fps, menu basically unclickable on anything, absolutely unplayable, have played previously before upgrading my Motherboard, CPU and Ram without issues, and the upgrades are better than what I was using

Reproduction Steps:
Start the game




Details of any solutions that have already been attempted:
Tried assigning all cores to the process
Updating/Reinstalling GPU Drivers
Reinstalling the game
Different resolutions/graphical settings

Comments

  • Spielen1Spielen1 Registered Users Posts: 1
    Hi I've also been experiencing these issues since upgrading to an i5-12600k and I've been able to completely solve the stuttering by going into my BIOS and manually disabling all E-cores. I tried to use 'Legacy Game Compatibility' mode in the BIOS first but that didn't solve anything so I don't think that option is working as intended.
  • obiwan11197obiwan11197 Registered Users Posts: 2
    Agreed. Recently upgraded to an i7-12700k and the menu and game's frames have absolutely grinded to basically a halt. Seems ridiculous to have to switch the BIOS settings for resolution if it works as Spielen1 says.
  • Ashbery76Ashbery76 Senior Member Registered Users Posts: 617
    I had this with my 12600k.Please fix this.
  • Boris_JohnsonBoris_Johnson Registered Users Posts: 1
    I also changed my processor for an I7-12700K and since then I have very low FPS when starting the game and huge lag even in the menu it became unplayable, an update to fix this problem would be a good thing without which I can put this game in the closet...
  • jimmywsjimmyws Registered Users Posts: 1
    HEY DUDE
    PLEASE READ THIS

    i fix this problem

    1.Open game
    2.Open Task Manager
    3.Click "detail" section
    4.Find "total war three kingdom"
    5.Right click then, click affinty
    6.Set amount number of cores to all (activated all cores)

    hopes this work for you
Sign In or Register to comment.