Welcome

Please register for Total War Access to use the forums. If you're an existing user, your forum details will be merged with Total War Access if you register with the same email or username. For more information please read our FAQ’s here.

Categories

Incompatible version issue for crossplay between Steam and PC Game Pass caused by Launcher

MightfoMightfo Registered Users Posts: 201
Ran into issues playing modded WH3 with friends who were using PC game pass.

Here's what we did, which demonstrates the source of the issue:

1)We used the exact same mod, with no other mods, thus the exact same load order.
We had 2 steam players and 2 PC game pass players.
If a steam player hosted, for PC game pass players it would say the version was incompatible if they tried to join, but the other steam player could join fine.
If a PC game pass player hosted, for steam players it would say the version was incompatible if they tried to join, but the other gamepass player could join fine.

In both of these scenarios, we checked the version etc in the top right of the main menu. We had exact same versions, but still got this error.


2)If we turned off all our mods, we could join each others multiplayer campaign rooms, no problem. So it wasnt simply an issue between steam and PC game pass.

3)If we disabled all mods and then placed the same "movie" style mod(a mod that loads automatically, rather than being toggled on/off by the launcher) in each of our data folders, we could join each others multiplayer campaign rooms with problem!

So the issue is not mods and versions inherently, it is that there is some sort of difference between the launcher of Steam WH3 and the launcher of Pc Game Pass WH3 that makes versions interpreted differently if mods are used.


Guide for enabling mods on game pass, for those curious: https://www.reddit.com/r/totalwar/comments/u1rka8/modding_warhammer_3_game_pass_guide/

Comments

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file