Please register for Total War Access to use the forums. If you're an existing user, your forum details will be merged with Total War Access if you register with the same email or username. For more information please read our FAQ’s here.


In ProgressUnable to Start Realm of Chaos Quest After Entering From Another Realm (Gamebreaking)

Epiphany_HSEpiphany_HS Registered Users Posts: 3
edited May 2022 in Campaign & Battle Bugs
I entered the Realm of Nurgle from the Realm of Khorne because the weapons I wanted were being held by another faction.

Upon entering the Realm of the Plaguelord I did not get the quest, I tried waiting a turn to see if it would start (on Legendary) and it did not.
I am able to replicate this bug by travelling from Nurgle to Khorne (the Khorne quest doesn't start either, fixed upon reload by leaving the realms altogether then re-entering)

The bug became Gamebreaking after I tried staying in Nurgles realm for one turn, now I cannot get the 'Realm of the Plaguelord' quest under any circumstances, including waiting for the realms to close and reopen. Unable to fix my campaign due to Legendary difficulty.
Post edited by [Deleted User] on


Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file