Welcome

Please register for Total War Access to use the forums. If you're an existing user, your forum details will be merged with Total War Access if you register with the same email or username. For more information please read our FAQ’s here.

Categories

In ProgressRight Click + Drag Formation orders not working as expected

TotalWyrm#9488TotalWyrm#9488 Registered Users Posts: 10
edited May 2022 in Campaign & Battle Bugs
Since 1.2, there's been new & irritating behavior with giving formation move orders using Right Click + Drag.

There's always been buffer distance you had to move your cursor before the formation is unlocked and allowed to stretch/narrow/rotate, but this buffer feels like it was changed in 1.2. Before, I could narrow the formation directly by moving the cursor inwards/left, and the unit would unlock and squish itself into a single file. Now, the unit only unlocks if I drag the cursor a significant distance outwards/right to stretch the formation, and only once the formation has been stretched can I adjust it back down to be narrow.

In addition, if a movement order is given (right click is released) while the formation is still locked by the buffer, the destination of the unit's formation will differ from the predicted highlight by a significant margin - made worse when zoomed out. It appears to still be using the cursor's absolute position for the unit's destination, even while the unit's predicted destination is locked by the buffer.
Post edited by CA_Dimitar#6718 on

Comments

  • Runix#6263Runix#6263 Registered Users Posts: 43
    I'm having the same issue as well. Click-drag is wonky, mostly for single units, and it feels like it's worse closer to terrain obstacles.
  • LaindeshLaindesh Junior Member Registered Users Posts: 4,738
    edited May 2022
    Same issue, right click and drag is laggy\buggy, like really wonky. Sometimes the unit dont even position itself where i mark it to be. Like i drag the unit into formation when setting up the battle field and the unit appear in a different nearby spot instead. Its weird.

    First battle as Miao Ying, positioning the cavalry in the left side "forest" near the white border and the unit positions itself at the south edge of the forest instead. The misspositioning is that bad.

    edit: mostly happens the further out i zoom.
  • SusaVile#9835SusaVile#9835 Senior Member Registered Users Posts: 1,430
    Going to ask you guys to replicate that issue, I have a theory that this may be linked to tooltips. Basically, a tooltip shows up, and it never actually leaves (the screen area where it showed up becomes impassable terrain, regardless where you move it; hence, you try to click and drag, there is impassable terrain, and it feels clunky; you move the screen a bit, and that area you wanted to click is now possible). @Laindesh you said you were using Miao Ying and some cavalry, may I ask which unit of cavalry? Any specific spells you had with Miao Ying, or tooltips that may have shown up?

    These may be yet unrelated, of course.

    I found the same situation 100% happens with the "victory" banner in the end of any battle. It disappears, but it is always there, and if you move the screen the area in the screen where that message showed up is marked impassable to deploy and put units, because the banner seems to still be there.
    Always learning, be polite, unless he's the enemy:P
    Cheers
    SusaVile
    Total war youtuber
  • LaindeshLaindesh Junior Member Registered Users Posts: 4,738
    To e
    SusaVile said:

    Going to ask you guys to replicate that issue, I have a theory that this may be linked to tooltips. Basically, a tooltip shows up, and it never actually leaves (the screen area where it showed up becomes impassable terrain, regardless where you move it; hence, you try to click and drag, there is impassable terrain, and it feels clunky; you move the screen a bit, and that area you wanted to click is now possible). @Laindesh you said you were using Miao Ying and some cavalry, may I ask which unit of cavalry? Any specific spells you had with Miao Ying, or tooltips that may have shown up?

    These may be yet unrelated, of course.

    I found the same situation 100% happens with the "victory" banner in the end of any battle. It disappears, but it is always there, and if you move the screen the area in the screen where that message showed up is marked impassable to deploy and put units, because the banner seems to still be there.

    It was with miao ying's starting army against the rebels she fights turn 1. So the cavalry is the peasant cav unit she starts with :) Note that infantry seemed fine.

    The issue persisted with and without mods.
  • CA_Dimitar#6718CA_Dimitar#6718 Registered Users, Moderators, CA Staff Posts: 1,002
    Hey all,

    Thanks for the detailed reports. This issue has already been sent to the dev team.

    Cheers,
    Dimitar
  • LaindeshLaindesh Junior Member Registered Users Posts: 4,738
    update: Did a bit more testing, infantry has click drag delay too. Its not as bad as the cav who got it no matter what, but they do have it if you try to drag it vertically when the unit is horizontal.
  • vladyskaizenvladyskaizen Registered Users Posts: 23
    I just had a battle with this issue and didn't understand what was going on. My units were facing the wrong way. Now I realize it was this. Not playing until it's resolved, super annoying!
  • NickCageStoleMyFace#5594NickCageStoleMyFace#5594 Registered Users Posts: 2,758

    I just had a battle with this issue and didn't understand what was going on. My units were facing the wrong way. Now I realize it was this. Not playing until it's resolved, super annoying!

    This needs to be hot fixed, I don’t wanna wait another 1 and a half months too.

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file