Please register for Total War Access to use the forums. If you're an existing user, your forum details will be merged with Total War Access if you register with the same email or username. For more information please read our FAQ’s here.


Unable to continue multiplayer campaign after update

Artres#5852Artres#5852 Registered Users Posts: 3
v1.7.1 17625.2613664

Save Build:
v1.7.1 17233.2290568

Detailed description:
The button labelled "Resume As A Host" to continue the campaign is greyed out after the most recent Steam update was downloaded. The saves are still present on both of our computers.

Reproduction Steps:
- Be on the current latest version, 1.7.1 17625.2613664, released on Steam around Jun 21, 2022
- Go to the multiplayer page
- Notice that it's not possible to host a game that was saved with the 1.7.1 17233.2290568 build released around May 27, 2021

As both me and the host are using Windows machines, I can't say whether this is also an issue on any other OS (though I doubt there would be any difference, this seems to be a version/build mismatch issue). I've attached a player save (no idea if the host's is different), but I had to change the file extension (it should be ".save_multiplayer", not ".save") since the HTML file input artificially restricts the file extensions it accepts.

Details of any solutions that have already been attempted:
At first we thought it might be because of the game being considered "modded" (note, neither me nor the host have ever run any mods on Three Kingdoms), so we used Steam to verify the integrity of our game caches. No files were out of order. Next we tried backdating to the 1.7.0 version (build 16713.2221481) included in the Betas section. We were able to start hosting and got to the join-up screen, but almost immediately after loading started we were kicked back to the title screen (we tried this multiple times without success).

After that, I dug around in the log "modified.log" (under the Three Kingdoms' app data folder). After finding that the "manifest.txt" file under "/Total War THREE KINGDOMS/data/" was missing (and remained missing no matter how many times I deleted files/folders and had Steam check Three Kingdoms' file integrity), I recreated it based off of the version of the file that existed in the aforementioned 1.7.0 version. After massaging it and getting all the files that "modified.log" told us we needed, and at the right sizes, the game was no longer considered "modded" (do note that version 1.7.0 was still considered modded, and as far as I could tell it was just because the contents of the "manifest.txt" file were incorrect, even after checking file integrity multiple times). This, however, did not result in the "Resume As A Host" button being clickable for the original host (or as the other player, predictably, since non-hosts aren't allowed to rehost an existing save).

My best stab at solutions that are out of my control:
The first option (and the laziest, and the most likely to succeed) is to have the previous 1.7.1 17233.2290568 build listed as a Beta on Steam that can be rolled back to. This would almost assuredly allow saves from that build to be hosted again.

The second option would be to relax the version/build exclusion logic so that saves made on old versions/builds would be hostable on the new version/build (at the host's own peril). This is likely a time-prohibitive option with limited future utility.

If you need any other information or one of the host's saves, feel free to ask and I'll supply whatever I can.


  • steam_164509111509lgFwRVjsteam_164509111509lgFwRVj Registered Users Posts: 19
    Same for a lot of player bro, no solution yet and the CA team are saying that this is because of mod, where a lot of player, me including where playing vanialla campaign.
  • Parameq#5420Parameq#5420 Registered Users Posts: 6
    Thank you for this post. More effort than the devs.
  • Artres#5852Artres#5852 Registered Users Posts: 3
    edited July 2022
    This is just a reminder that I still have not found a workaround to this, let alone a solution. I understand from the developers' and management's point of view that there is no upside to responding, in all likelihood we're going to be either frustrated with a negative answer or impatient with a positive one. However, receiving neither a "we have limited manpower and can't work on this" nor a "a fix might be coming soon™, but it isn't ready yet" is equally frustrating from our point of view because we can't plan around a response that hasn't been made.
  • Parameq#5420Parameq#5420 Registered Users Posts: 6
    This is simply pathetic. Why would I bother to buy 3K 2, after the mess the patches have made of this game over its lifespan? And now this, literal ignorance.
  • steam_164509111509lgFwRVjsteam_164509111509lgFwRVj Registered Users Posts: 19
    I will defently not buy 3k2 neither, I never felt so angry and frustrated about any game in my entire life, what a waste of time.
  • Artres#5852Artres#5852 Registered Users Posts: 3
    edited December 2022
    For the benefit of anyone who found this thread looking for answers, unfortunately it has been almost 6 months and I still haven't found a solution on my own. This entire experience has left a bitter taste in my mouth.

    From my perspective, it is incredibly galling. One of the reasons that my multiplayer buddy and I picked Three Kingdoms was because we were pretty sure that there weren't going to be any save-breaking patches/updates made to the game, which was important because of how little free time we have, and how long our campaigns normally go. Then, right as we were entering the endgame, there was a patch that didn't even change the game version, but which nevertheless prevented us from even loading the save. To rub salt in the wound, from what I can tell, the only changes made to the game were adding language packs in preparation for the game going on Microsoft's Game Pass service, changes which were also pushed to Steam regardless of their lack of necessity. The last saving grace would have been to offer the old build as a rollback Beta (which they've done for 1.4.1, 1.5.3, 1.6, 1.6.1, 1.7.0, and several Mac/Linux builds/versions), but even that minimal time investment has been a bridge too far for the devs/managers.
Sign In or Register to comment.