Welcome

Please register for Total War Access to use the forums. If you're an existing user, your forum details will be merged with Total War Access if you register with the same email or username. For more information please read our FAQ’s here.

Categories

Warhammer 3 crash - After battle

SadharvesterSadharvester Registered Users Posts: 2
edited July 12 in Crashes
So I recently bought on STEAM Warhammer 3 to play with friends and some campaing.

Every time I play my game crashes after battle. If I auto-play battles I can advance the campaign but if I want to play by myself I can not.

I had WH2 and it worked fine with worse PC.

My PC:

Processor: AMD Ryzen 7 2700X Eight-Core
Graphic Card: NVIDIA GeForce RTX 3070
16GB RAM

Game is installed on SSD.


List of things I tried to fix it:

1 Verify the game files
2 Update graphics driver
3 Installed the latest game patch
4 Start game as -dx11
5 Disable third-party antivirus software
6 Run as administrator
7 Changed settings (lowered them, maxed them, windowed, full screen etc)
8 I dont use mods
9 Reinstalled game twice

I dont have game crash info becouse it looks like I would alt + F4.

Do you have any idea what to do?
Post edited by BillyRuffian#6250 on

Comments

  • ReeceWhitReeceWhit Registered Users Posts: 1
    I’m currently having the same issue. Battle ends, screen turns gray. Not all the time but most of the time it seems.

    Was fine before the latest patch which I installed yesterday. Wonder if that has something to do with it?
  • dddongdddong Registered Users Posts: 1
    edited July 11
    Has no problem till 140+ turns, after a battle it just crash the game consistently and corrupt the most recent 2 saves.
    my set up is win11 RTX3090 graphic card

    this basically make the game unplayable and I want my 30hr+ campaign back!
    ==================
    And I just verified, all my saves! not only recent auto-save of that campaign are corrupted!!! I lost a 30hrs+ campaign because this stupid bug.

    I do try restart a new campaign and finish a battle without issues. This is so annoying, the crash also impact all my save on that campaign which is beyond tolerance
    Post edited by dddong on
  • LeLLsLeLLs Registered Users Posts: 5
    I could have listed everything just as you did. I really treid it all and i also dont know what could possibly cause this problem. Did you guys fix it till now or do you still have these problems? Cause i do.
  • azuldruideazuldruide Registered Users Posts: 9
    edited July 23
    Hello Sadharvester,

    i have almost the same issue => crash_report => D2022-07-21_T21-06-23.stack.txt :
    Warhammer3
    ntdll
    ntdll
    ntdll
    Warhammer3
    Warhammer3
    Warhammer3
    Warhammer3
    KERNEL32
    ntdll

    TWW3 crash during almost all battles :(

    my graphic card is Nvidia GeForce RTX 3080 , driver v.516.59 game ready

    Best wishes
  • PatLPatL Registered Users Posts: 2
    edited August 31
    Same issue, game crash after fight in main campaign. Bought it on steam and can't play.
  • loutheloulouthelou Registered Users Posts: 6
    edited September 2
    Try changing your Texture Quality setting to Medium. Fixed it for me.

    Mine was set to Ultra by default, which it automatically scaled down to High due to lack of memory. A reddit post found a number of people fixing their problem by changing that setting to Medium. As it did for me; it was CTD immediately following the first battle in the tutorial. Not anymore.
    dddong said:

    Has no problem till 140+ turns, after a battle it just crash the game consistently and corrupt the most recent 2 saves.

    ...

    I do try restart a new campaign and finish a battle without issues. This is so annoying, the crash also impact all my save on that campaign which is beyond tolerance

    That sounds like a separate issue.

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file