Welcome

Please register for Total War Access to use the forums. If you're an existing user, your forum details will be merged with Total War Access if you register with the same email or username. For more information please read our FAQ’s here.

Categories

User Info RequiredAlarielle's bonuses on regions gone after confederation (No mods)

BoulderpuncherchrisBoulderpuncherchris Registered Users Posts: 15
v2.1.1 Build
16218.2683626

I confederated Alarielle but she stopped providing her bonuses to regions anymore. Before the confederation, I was able to see the mark and bonuses she left on regions where she ends her turn. After 5 turns of the confederation, she still can't do that.

Apparently, loading a save immediately after something happens on legendary difficulty breaks the game. I quit the game on the turn I did the confederation. After I came back to play, I noticed the bug. In another campaign when I was playing Lizardmen, I saved and loaded the game right after I got Lord Kroak. His equipment items were all gone (empty equipment slots) after the load.

I can not try and reproduce the bug because I'm playing on legendary difficulty. Confederating her was also a miracle. It would be hard for me to test again.
Post edited by CA_Liam#6659 on

Comments

  • MattSuzakiMattSuzaki Registered Users Posts: 1
    That happened to me too, thought i was missing something.
  • #32856#32856 Registered Users Posts: 1
    Yeah, very disappointing. Hopefully fixed soon. Wish there was a mod to add it back in...
  • Winterly#4303Winterly#4303 Registered Users Posts: 11
    Confirmed bug is still present in Immortal Empires, December 18, 2022.
  • #749215#749215 Registered Users Posts: 2
    They aren't going to fix this, they are not fixing anything. They did make some new desktop wallpapers in the past few months since release, that's about it...
  • CA_Liam#6659CA_Liam#6659 Registered Users, Moderators, CA Staff Mods, CA Staff Posts: 235
    Hey all,

    I wasn't able to reproduce this, could see the game implementing the same control & character buffs as before she was confederated. Can you please advise what you're looking at in a bit more detail? I've tried 2 factions and can confederate with Alarielle's shining light still showing in a province as well as the benefits but want to make sure I'm not missing anything given how long this has been happening & affecting quite a few people.

    All the best,
    Liam
    Disclaimer: Any views or opinions expressed here are those of the poster and do not necessarily represent the views or opinions of The Creative Assembly or SEGA.
  • #63907#63907 Registered Users Posts: 8
    edited March 16
    Confirmed this is still happening in my Eltharion campaign today. Alarielle not providing buffs in provinces in Immortal empires after confederating. (Edit: looks like thorek is finally getting fixed :)Also when are you guys gonna fix the Thorek Ironbrow/Karak Zorn confederation quest that's been broken since beta started?

    Really getting frustrated with getting 50+ turns into campaigns to find there some major bug that makes me want to quit it.

    Build 2.4.0

    Worth noting she was wounded when I confederated her, 1 of her princesses also has sword of khaine. Nothing else of note. Apparently this has been an issue since August...

    https://steamcommunity.com/app/1142710/discussions/1/3431201423153674042/
    Post edited by #63907 on
  • #63907#63907 Registered Users Posts: 8
  • Adohleas#7748Adohleas#7748 Registered Users Posts: 2
    I reported this issue last year in September on steam, and today I just confederated Alarielle again and she still doesn't give the bonus to settlements she visits. I still see the glow from the previous settlements she visit before she was confederated, but there are no bonuses being applied and visiting other settlement isn't giving that radiant bonus.
  • CA_Tama#5904CA_Tama#5904 Registered Users, Moderators, CA Staff Mods, CA Staff Posts: 334
    Hey everyone,

    Could any of you please provide save.files and mod.logs. So we can better investigate this.
    You can find out how to upload these here

    Thank you for your patience
    Tama ^-^
    Formal disclaimer: any views or opinions expressed here are those of the poster and do not necessarily represent the views or opinions of The Creative Assembly or SEGA.
  • Adohleas#7748Adohleas#7748 Registered Users Posts: 2
    edited March 23
    I just made another game with another faction but did easy difficulty so I could rush confederated her again and saved the before confed and after save file and I'll upload the logs too:
    v2.4.0 Build
    19051.2806817

    As you can see, she is not giving her radiant bonus to any settlements she visits when I confederated her.
    When you end turn in any settlement with her, you see no radiant icon that normally shows up and no growth bonus, no control bonus, and no influence bonus in the settlement that she normally would give.

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file