Please register for Total War Access to use the forums. If you're an existing user, your forum details will be merged with Total War Access if you register with the same email or username. For more information please read our FAQ’s here.


Game looks bad on 32 inch monitor

#983429#983429 Registered Users Posts: 3
I have a 2k quality MSI 32 inch monitor. At native resolution, the game looks bad. Like it's been stretched to fit.
This is not a problem with ANY other non total war game I have, they all look great.
I have correct graphics/display options and have tried every variation to fix. I have tried sharpening up the game in nvidia control panel. Doesn't work.
Only conclusion I can draw is that the game is somehow not optimised for large screens? It still doesn't look great when I put it into windowed mode and play at a lower res.
Any fixes to this please?


  • #983429#983429 Registered Users Posts: 3
    To add, it looks like the game is a lower resolution than it really is.
  • #983429#983429 Registered Users Posts: 3
    It is not the UI scaling either. That is improved by making it smaller (not sure why it isn't just optimised to look good when larger) but it's also the actual game graphics.
  • qap#3862qap#3862 Registered Users Posts: 4
    edited March 20
    Nvidia control panel.

    Try enabling DSR - Factors. Tick 1.78 and 2.25

    DSR Smoothness, put to 0 to make it max sharpness.

    Load the game and set to full screen away from window mode, so then it enables use of UI scaling and will show more resolution options.

    Try out 2 of the higher resolutions that shows up in Warhammer graphics options. 3200×1800 first or 3840×2160

    Enable TAA High

    It does wonders on my 1080p monitor if I enable DSR.


Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file