Please register for Total War Access to use the forums. If you're an existing user, your forum details will be merged with Total War Access if you register with the same email or username. For more information please read our FAQ’s here.


Warhammer 3 boot loop

6655321tom#56676655321tom#5667 Registered Users Posts: 1
I haven't picked up the game for a few weeks, the last time I played was after the immortal empires update and everything worked fine. About a week ago I tried to load up the game and after clicking launch from the launcher the launcher disappears, nothing happens for 2-3 seconds, then the launcher appears again. This has been happening ever since, and I can't figure out why. My troubleshooting steps so far:
- uninstall + reinstall Total War Warhammer 3
- verify integrity of game cache (pre and post uninstall)
- deleted all mods
- uninstalled + reinstalled microsoft visual c++
- clean graphics card drivers install
- uninstalled + reinstalled steam
- ran .exe as administrator
- ran .exe in compatability mode
- ran through steam in windowed mode
- ran through steam in -dx11 mode
- ran system file checker
- ran chkdsk
- performed regedit as mentioned in this forum post: (https://forums.totalwar.com/discussion/318346/total-war-warhammer-iii-refuses-to-launch)

The only thing that seems to modify any behaviour is that when I use arguments in steam launcher (-windowed, -dx11) the game only loops once - after I click launch initially in steam the total war launcher pops up, then after I click launch, the launcher disappears and nothing happens. No task in task manager etc.

System specs:
Windows 10
AMD Ryzen 9 5900x
ROG Strix B550-I
32GB corsair RAM

Thank you for any thoughts/assistance, my next troubleshooting step will be a clean windows install but that's a bit of a hassle

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file