Welcome

Please register for Total War Access to use the forums. If you're an existing user, your forum details will be merged with Total War Access if you register with the same email or username. For more information please read our FAQ’s here.

Empire on Windows 8

krishemphillkrishemphill Junior MemberPosts: 1Registered Users
edited December 2013 in Total War Eras Support Forum
I'm upgrading my computer soon and the best I've found for a decent price uses windows 8. All the info I found on empire's system requirements only said it works on windows 7 at the latest.
Is it able to run on windows 8?
Post edited by krishemphill on

Comments

  • DarKDarK Tech Moderator Posts: 639Tech Moderators
    edited August 2013
    I don't see why not, both Windows 7 and 8 are both essentially architecturally identical. And it's had long enough for drivers to balance themselves out in to a stable manner.

    You might want to make sure the CPU and GPU in the system is going to be enough for your needs now and in the future though.
  • frigginjoefrigginjoe Senior Member Posts: 334Registered Users
    edited September 2013
    Runs quite well on my second PC using Windows 8.
    i5 2500K @ 4.5ghz | nVidia GTX 770 OC 4gb
    FX-8320 @ 3.5ghz | Radeon HD 7870 2gb
    http://www.pocketpiglets.com/private/custominf.html (in case it helps)
  • Henning61Henning61 Junior Member Posts: 1Registered Users
    edited October 2013
    I upgraded to Windows 8.1 and should of course have known better. Graphics in TWE got all distorted, pinkish in colour and like watching a 3d-movie without 3d-glasses. Now I can't play.

    Graphis card is GeForce GTX650 Ti Boost.

    How shall I deal with this?

    Was adviced to upgrade with GeForce 331.40 beta driver, but hesitates. Suggestion anyone? All help appreciated.

    Rgds
    H.
  • badger_warriorbadger_warrior Junior Member Posts: 1Registered Users
    edited December 2013
    Henning61, I had the same issue with the stereo being on by default. I did this: Go to the Nvidia Control panel and look for the stereoscopic 3D tab. Just disable the stereo which has been set to be on by default, I guess as part of the 8.1 upgrade? Try that and see if it remedies the situation.
Sign In or Register to comment.