Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Adorbs

Cannot Launch Rome 2 Total War

Count RaviolliCount Raviolli Senior MemberPosts: 119Registered Users
edited September 2013 in Total War Eras Support Forum
I have a serious issue. I pre-ordered the game and was all excited when it came out over a week ago.
I have still not been able to play it.
When I try to launch (through steam, the shortcut, or by running Rome 2. exe), a steam window pops up that says "preparing to launch Total War- Rome 2..." and does nothing. The window closes, and NOTHING HAPPENS. When I try to click on the Rome 2 launcher in the Rome 2 folder, it says that I'm not connected to steam, EVEN THOUGH I'M CONNECTED TO STEAM!!!!!
As a side note, when I installed (steam said it installed correctly), and clicked "Run Rome 2 total war" it got to step 5/10 of the initial setup before doing the same thing. The window closed, and nothing happened...
I've tried most of the solutions on these forums, (full lobotomy, log-in-log-out, ever patch available...), and NOTHING. While I feel that moaning about the game has been quite adequately covered by my fellow forum-dwellers, i still am compelled to say:
WHY CAN'T ANYTHING JUST FREAKING WORK!!!!!!!!!!!????????????????
Post edited by Count Raviolli on

Comments

  • Count RaviolliCount Raviolli Senior Member Posts: 119Registered Users
    edited September 2013
    P.S.
    I'll post my dxdiag but an error pops up that says it's too long. I've seen it posted where you're able to scroll down... how do you do that?
  • adam0912sadam0912s Junior Member Posts: 7Registered Users
    edited September 2013
    Did you find a solution? I still have this problem......
  • Count RaviolliCount Raviolli Senior Member Posts: 119Registered Users
    edited September 2013
    As it turned out, my solution was so simple, I look like a complete idiot to every tech support chum in the Total War system. See, my drivers refused to update via the internet (steam, AMD, windows scan, you name it) because they thought they had the latest drivers. So I just downloaded the latest driver to a USB, plugged it in, told windows to update drivers from that file and now I'm fine. The game is EPIC (though performance is... arg...)
Sign In or Register to comment.