Welcome

Please register for Total War Access to use the forums. If you're an existing user, your forum details will be merged with Total War Access if you register with the same email or username. For more information please read our FAQ’s here.

Categories

Having a problem with the RTW 1.5 patch - says it can detect Gold![Solution]

palantirionpalantirion Junior MemberPosts: 17Registered Users
edited March 2011 in Technology
I have the 3 disks for Rome installed into the Activision subfolder (1.0) and have just applied the 1.3 patch. However, when I try to apply the 1.5 patch it says I have RTW Gold installed already and will not allow me to proceed.

I also have a digital version of Rome Gold, patched to 1.6, in "the Creative Assembly" folder. However, my Alexander CD from the Eras pack will not work when I install it with this digital version for some reason, so I am trying to patch up the CD RTW version so I can try Alexander on that.

My BI CD is, alas, ruined after too much use

Can anyone help?
Post edited by palantirion on

Comments

  • AlJabberwockAlJabberwock Moderator USAPosts: 7,729Moderators, Tech Moderators, Knights
    edited March 2011
    Sorry man, I have no hard info on this, but I do have a guess. The 1.5 source for the patch will tell you be certain you have chosen the right version. YOu may THINK you have chosen the right version, but you need to verify that as well as the version being for the country you are in. Secondly, it may be that the source for the 1.5 patch is using one that is looking only in the steam/CA folder.

    While I would not want to tell you what my idea would be for trying to work around that, I do not have the ALexander expansion nor any experience with working with that. Bummer on the BI as that has to be my favorite expansion, with Teutonic and Crusade right behind... Perhaps one of these really bright folks has dealt with that. A long-winded, but well intentioned 'bump' ;)
    ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    “Every so often things happen that can’t be rationalized in a conventional way. People wanna know their government has a response. I am that response.”
    ― Kent Mansley (in "Iron Giant")

    For most general problems, for which you have no idea of the culprit, your first port of call should be:
    https://support.sega.co.uk/hc/en-us/categories/200307381-Total-War-Support

    If you are aware of a bug or a specific issue for which you know the cause, post in the support section for the specific title on our forums. ~Al

    https://forums.totalwar.com/discussion/172193/forum-terms-and-conditions#latest
  • palantirionpalantirion Junior Member Posts: 17Registered Users
    edited March 2011
    I've tried a 1.5 version from two different sources and both report the same issue. I am from England a non-English versions tend to have _us or something appended to the file name anyway. I think the 1.5 (unlike the 1.3) might be for all countries anyway as I have not seen different versions.

    I can play BI via my digital version of Rome Gold BUT that installation will not allow me to install a playable version of Alexander (in CD form) to it. It is UTTERLY ridiculous that you have to get the game in the same format (apparently) for it to work.

    In order to install Alexander to my CD version I need to patch up to 1.5 but, as I say, the installer will not install it because it says I already have Rome Gold. I can only guess it is somehow detecting the digital version. The digital version is a pain to activate (I had to get Trymedia to manually do it for me from their end last time), so I don't want to have to uninstall the digital version except as a last resort...though I'm getting to that point.

    Why o why don't they think these things through before releasing them..or at least provide fixes...
  • palantirionpalantirion Junior Member Posts: 17Registered Users
    edited March 2011
    OK, uninstalled Gold (let's hope I can install it again!) and tried to reply the patch - it now tells me that no installation of Rome TW is installed. This is weird. I've patched up to 1.6 dozens of times when I had the BI disk working. Is there something inherently wrong with the 1.5 patch?


    EDIT: OK, this issue us now resolved. I uninstalled the Trymedia Gold Version, changed the CD path version from the Activision folder to a "The Creative Assembly" one. Then I set up the registry for Rome for that latter path and then 1.5 patch worked (and thus also the CD version of Alex could be installed). I then reinstalled the Trymedia version to a different folder. My conclusion is that, at very least, the 1.5 patch expects a "The Creative Assembly" folder; which is strange because I know the 1.6 patch does not. Hope this helps someone in the future!
Sign In or Register to comment.